aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-bitstream-100dpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-bitstream-100dpi/APKBUILD')
-rw-r--r--main/font-bitstream-100dpi/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/main/font-bitstream-100dpi/APKBUILD b/main/font-bitstream-100dpi/APKBUILD
index 87c59e16057..5a5dcb2bd71 100644
--- a/main/font-bitstream-100dpi/APKBUILD
+++ b/main/font-bitstream-100dpi/APKBUILD
@@ -1,18 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=font-bitstream-100dpi
-pkgver=1.0.3
-pkgrel=1
+pkgver=1.0.4
+pkgrel=2
pkgdesc="X.Org Bitstream bitmap fonts"
-url="http://xorg.freedesktop.org/"
-arch="all"
-license="custom"
-depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+url="https://xorg.freedesktop.org/"
+arch="noarch"
+license="MIT"
+options="!check"
+depends="encodings font-alias mkfontscale fontconfig"
makedepends="font-util-dev bdftopcf"
-source="https://www.x.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
-
-prepare() {
- update_config_sub
-}
+source="https://www.x.org/releases/individual/font/font-bitstream-100dpi-$pkgver.tar.xz"
+subpackages="$pkgname-doc"
build() {
./configure \
@@ -25,11 +23,15 @@ build() {
}
package() {
- make -j1 DESTDIR="$pkgdir" \
+ make DESTDIR="$pkgdir" \
MKFONTDIR=: \
MKFONTSCALE=: \
FCCACHE=: \
install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="10fd920d46d2cb1b314e8c2f05c202e9ffa74a4e5315f34790eba8bd8fcda865a6932eb712a7538624e69367647bcd6891e7015099e65463aeef772d0ba58bfd font-bitstream-100dpi-1.0.3.tar.bz2"
+sha512sums="
+1389681eee8b9e2bbfe0293b0aa1add7c6fa86149ff3cb779195ddcc548b1a519336c2d43b6988c899dc09d44ca30de9ffb5daca24fc3906694ab0fd391eb437 font-bitstream-100dpi-1.0.4.tar.xz
+"