aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-bitstream-75dpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-bitstream-75dpi/APKBUILD')
-rw-r--r--main/font-bitstream-75dpi/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/main/font-bitstream-75dpi/APKBUILD b/main/font-bitstream-75dpi/APKBUILD
index b4df4921c43..e8332a0605d 100644
--- a/main/font-bitstream-75dpi/APKBUILD
+++ b/main/font-bitstream-75dpi/APKBUILD
@@ -1,18 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=font-bitstream-75dpi
-pkgver=1.0.3
-pkgrel=1
+pkgver=1.0.4
+pkgrel=2
pkgdesc="X.Org Bitstream bitmap fonts"
-url="http://xorg.freedesktop.org/"
-arch="all"
-license="custom"
-depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+url="https://xorg.freedesktop.org/"
+arch="noarch"
+license="MIT"
+options="!check"
+depends="encodings font-alias mkfontscale fontconfig"
makedepends="font-util-dev bdftopcf"
-source="https://www.x.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
-
-prepare() {
- update_config_sub
-}
+source="https://www.x.org/releases/individual/font/font-bitstream-75dpi-$pkgver.tar.xz"
+subpackages="$pkgname-doc"
build() {
./configure \
@@ -25,11 +23,15 @@ build() {
}
package() {
- make -j1 DESTDIR="$pkgdir" \
+ make DESTDIR="$pkgdir" \
MKFONTDIR=: \
MKFONTSCALE=: \
FCCACHE=: \
install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="9311a5b0cbe1613aca87fdf7fd9ab263eb1129e3c3eacbce54547f2185e151fb1237128b1b6d39f716f28694a486909564ecc9a0aef061438622d11b5661d650 font-bitstream-75dpi-1.0.3.tar.bz2"
+sha512sums="
+d678c58493696b3a744878991838b329243e5ba7985b1a435b62e9b1a05b5609d0b66d5943d840479ce2c5fc1da1b0633c33f28e3613712d26802fc41ee22c22 font-bitstream-75dpi-1.0.4.tar.xz
+"