aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-cronyx-cyrillic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-cronyx-cyrillic/APKBUILD')
-rw-r--r--main/font-cronyx-cyrillic/APKBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/main/font-cronyx-cyrillic/APKBUILD b/main/font-cronyx-cyrillic/APKBUILD
index 95610eef63e..13ed2f39927 100644
--- a/main/font-cronyx-cyrillic/APKBUILD
+++ b/main/font-cronyx-cyrillic/APKBUILD
@@ -1,40 +1,37 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=font-cronyx-cyrillic
-pkgver=1.0.3
-pkgrel=0
+pkgver=1.0.4
+pkgrel=1
pkgdesc="X.org cronyx cyrillic fonts"
-url="http://xorg.freedesktop.org/"
-arch="all"
+url="https://xorg.freedesktop.org/"
+arch="noarch"
license="custom"
-depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+options="!check"
+depends="encodings font-alias mkfontscale fontconfig"
makedepends="font-util-dev bdftopcf"
-install=
-source="https://www.x.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
-
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- update_config_sub || return 1
-}
+source="https://www.x.org/releases/individual/font/font-cronyx-cyrillic-$pkgver.tar.xz"
+subpackages="$pkgname-doc"
build() {
- cd "$srcdir"/$pkgname-$pkgver
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--with-mapfiles=/usr/share/fonts/util \
- --with-fontdir=/usr/share/fonts/cyrillic \
- || return 1
- make || return 1
+ --with-fontdir=/usr/share/fonts/cyrillic
+ make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make -j1 DESTDIR="$pkgdir" \
+ make DESTDIR="$pkgdir" \
MKFONTDIR=: \
MKFONTSCALE=: \
FCCACHE=: \
- install || return 1
+ install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="b926c425644f94548ad831c38573009ae97d207a05c9d8a917018c2518911960280eb3861ae11d99bc8d001fb0dca1967712fb70ba4f413bc9d6ac8ef904b456 font-cronyx-cyrillic-1.0.3.tar.bz2"
+sha512sums="
+39c0bfc08ac746fd98a668d7545da503e8413d5d66cdb1884489ed7221fa4f09dad8dc997ca39595113e2f12fd65de6d2bfd8eaf1480aa93d5eb961d2e2f7cff font-cronyx-cyrillic-1.0.4.tar.xz
+"