aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-util/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-util/APKBUILD')
-rw-r--r--main/font-util/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/main/font-util/APKBUILD b/main/font-util/APKBUILD
index 457f1e5520c..5f9c4e4c8b4 100644
--- a/main/font-util/APKBUILD
+++ b/main/font-util/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=font-util
-pkgver=1.3.2
+pkgver=1.4.1
pkgrel=0
pkgdesc="X.org font utilities"
-url="http://xorg.freedesktop.org/"
+url="https://gitlab.freedesktop.org/xorg/font/util"
arch="all"
license="custom"
options="!check" # No test suite.
@@ -11,10 +11,9 @@ depends="perl"
depends_dev="font-util"
makedepends="$depends_dev util-macros"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/font/font-util-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/font/font-util-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,7 +23,11 @@ build() {
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="7cac529b12ae71185b89c72c1569b9826f52eeaecc1c76010338e7c42c4078ae339f18220b580bbd68fb5dc09df6ecf169a47c32e6104d8ee53bd443fa21d167 font-util-1.3.2.tar.bz2"
+
+sha512sums="
+cec7fc38ba64ca9c81c59a8395da94d71c75e14f19faf6457da0a1a8c3c1cf51bcaab227834f6f5a6d274ba2557555e542dbe2bd88e527c45ea196318bbc38d0 font-util-1.4.1.tar.xz
+"