aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD108
1 files changed, 60 insertions, 48 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 547567d0b22..7f320a2c29a 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,46 +1,53 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Michael Mason <ms13sp@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
pkgname=freeswitch
-pkgver=1.10.6
-pkgrel=2
+pkgver=1.10.10
+pkgrel=1
pkgdesc="A communications platform written in C from the ground up"
-url="http://www.freeswitch.org"
+url="https://www.freeswitch.org/"
arch="all"
license="MPL-1.1"
+options="!check" # fixme: failing tests
makedepends="
+ apr-dev
+ autoconf
+ automake
bash
bsd-compat-headers
coreutils
curl-dev
diffutils
- flac-dev
flite-dev
gdbm-dev
- gnutls-dev
- ilbc-dev
lame-dev
ldns-dev
libedit-dev
- libexecinfo-dev
libjpeg-turbo-dev
- libogg-dev
- libpri-dev
- openssl1.1-compat-dev
+ libks-dev
libpq-dev
libshout-dev
libsndfile-dev
- libvorbis-dev
+ libsrtp-dev
+ libtool
linux-headers
lua5.3-dev
mpg123-dev
+ mariadb-dev
ncurses-dev
+ nasm
net-snmp-dev
+ openssl-dev>3
opus-dev
pcre-dev
perl-dev
portaudio-dev
+ py3-setuptools
+ python3-dev
sngtc_client-dev
+ sofia-sip-dev
+ spandsp3-dev
speex-dev
speexdsp-dev
sqlite-dev
@@ -48,31 +55,24 @@ makedepends="
unixodbc-dev
util-linux-dev
xmlrpc-c-dev
- yasm
zlib-dev
- sofia-sip-dev
- spandsp3-dev
- autoconf
- automake
- libtool
"
install="$pkgname.pre-install $pkgname.pre-upgrade"
_freeswitch_user=freeswitch
_freeswitch_group=freeswitch
pkgusers="$_freeswitch_user"
pkggroups="$_freeswitch_group"
-subpackages="$pkgname-static $pkgname-dev $pkgname-flite $pkgname-timezones::noarch
- $pkgname-sample-config:conf:noarch $pkgname-freetdm $pkgname-sangoma
- $pkgname-snmp $pkgname-pgsql $pkgname-perl $pkgname-perlesl
- $pkgname-openrc $pkgname-dbg"
+subpackages="$pkgname-dbg
+ $pkgname-dev $pkgname-flite $pkgname-timezones::noarch
+ $pkgname-sample-config:conf:noarch $pkgname-sangoma
+ $pkgname-snmp $pkgname-pgsql $pkgname-mariadb $pkgname-python3
+ $pkgname-perl $pkgname-perlesl $pkgname-openrc"
source="https://files.freeswitch.org/freeswitch-releases/freeswitch-$pkgver.-release.tar.xz
- 0002-FS-verto-bswap_64.patch
- configure-lua53.patch
- include-lua53.patch
getlib.patch
libvpx-fix-arm-float-abi.patch
disable-Werror.patch
+ python-3.10.patch
modules.conf
freeswitch.confd
freeswitch.initd
@@ -80,9 +80,17 @@ source="https://files.freeswitch.org/freeswitch-releases/freeswitch-$pkgver.-rel
builddir="$srcdir/$pkgname-$pkgver.-release"
+# secfixes:
+# 1.10.7-r0:
+# - CVE-2021-37624
+# - CVE-2021-41105
+# - CVE-2021-41145
+# - CVE-2021-41157
+# - CVE-2021-41158
+
prepare() {
default_prepare
- autoreconf -vif
+ NOCONFIGURE=1 autoreconf -vif
update_config_sub
}
@@ -100,31 +108,32 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-devrandom=/dev/urandom \
- --with-libpri \
+ --with-python3 \
--disable-debug \
--enable-core-pgsql-support \
--enable-system-lua \
--enable-system-xmlrpc-c
- # build libvpx with -j1, fails to find headers otherwise
make libs/libvpx/libvpx.a
- # build freetdm with -lexecinfo
- make -C libs/freetdm LIBS="-lexecinfo"
# first build libfreeswitch (in parallel)
make src/include/switch_version.h src/include/switch_swigable_cpp.h
make libfreeswitch.la
# finally we build the rest
- make -j1 all
+ make all
# build perlesl module
cd "$builddir"/libs/esl
- make -j1 perlmod
+ make perlmod
# deal with pkg-config version being bogus
cd "$builddir"
sed -i s:-release::g build/freeswitch.pc
}
+check() {
+ make check
+}
+
package() {
make -j1 DESTDIR="$pkgdir" install samples-conf samples-htdocs
@@ -142,12 +151,11 @@ package() {
_mv_mod() {
local moddir=usr/lib/freeswitch/mod i=
mkdir -p "$subpkgdir"/$moddir
- for i in $@; do
+ for i in "$@"; do
mv "$pkgdir"/$moddir/$i.so "$subpkgdir"/$moddir/
done
}
-
flite() {
pkgdesc="Freeswitch Text To Speech Module"
install=
@@ -161,14 +169,6 @@ flite() {
# mod_say_th mod_say_he
}
-freetdm() {
- pkgdesc="Freeswitch FreeTDM Module"
- install=
- _mv_mod mod_freetdm ftmod_analog ftmod_analog_em ftmod_libpri \
- ftmod_skel ftmod_zt
- mv "$pkgdir"/usr/lib/libfreetdm.so* "$subpkgdir"/usr/lib/
-}
-
sangoma() {
pkgdesc="Freeswitch Sangoma Media Transcode Codec Module"
install=
@@ -196,6 +196,12 @@ pgsql() {
_mv_mod mod_cdr_pg_csv
}
+mariadb() {
+ pkgdesc="Freeswitch MariaDB Module"
+ install=
+ _mv_mod mod_mariadb
+}
+
perl() {
pkgdesc="Freeswitch Perl module"
install=
@@ -209,8 +215,14 @@ perlesl() {
mv "$pkgdir"/usr/lib/perl5/* "$subpkgdir"/usr/lib/perl5
}
+python3() {
+ pkgdesc="Freeswitch Python3 module"
+ install=
+ _mv_mod mod_python3
+}
+
conf() {
- pkgdesc="Freeswitch sample configureation"
+ pkgdesc="Freeswitch sample configuration"
depends="freeswitch-timezones"
install=
mkdir -p "$subpkgdir"/etc/freeswitch
@@ -222,13 +234,13 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-sha512sums="1bb518cca959df73859d3e7a5980a5a98ffa3d092d1100fc5d2cce83da649fc6499feaa88d4ea0196149353f9af231ef8e4aeb089959c1ea75c0f98175c599c6 freeswitch-1.10.6.-release.tar.xz
-5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8 0002-FS-verto-bswap_64.patch
-222e3510790de29e29428c70325eb1d4e7852eb4315ee546f137293868bd71acf89e7c85c5ca9d0eb708090c9eef91878a8e12c1b9d5cc99a68fecbd42ad962f configure-lua53.patch
-c1960f3c7acf729468b819f7f15d66a251c3967b2784bce18c7755b333156e687c55fdc1aceda588ceb1bf9638e2fd4a31a169b00b15c5040cf1001c3c73913b include-lua53.patch
+sha512sums="
+b43079bc818a86bf667d9b328cf904e49c8455827c199c832ee686ff8634273ea186c35d907bed19d0474cbc2e1232d81624ae878a9aaa3b8897fd76e9916e55 freeswitch-1.10.10.-release.tar.xz
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
98a53f289c3647cafd05b6f847da0504a838a6e06545c133c10fb058c2d941e6bccf2820f44649fc25f94a4a5b7c1280eaee91098e8110f96ed3342c1cb4346c libvpx-fix-arm-float-abi.patch
16e9208fca7f0a1985dd01ec38ddabb6a79da83ad6ab004bb66de528ac45f02fadaddc50a9f228e1aa38fae213fa5af0ca858b7af629b67a7d654339f813a68c disable-Werror.patch
-ceeb2bb37fac580483000daff327a4c005d42b7eabdba4671ed2b0e78cddda8a42ae76e42bdf4a1b2e42874c4709887bcee9cb08a4c1dafcfeaec21e467726bf modules.conf
+4739be0c1c6783ace2bd10f7573b1ca86be013d21a7f973b5fd348c98fb9ed1a548baacee6bb65b7501251106c8dbd7266997f8699d2d7070a2bd7efe145b866 python-3.10.patch
+b2e4e5982e600098e00d5dce801f6159dc3d0765e9de5acc05492b4c811f399b4302c4c6a91d9788d8464d46d9c7a64b70a345130b97aa5a73da41acc57f67de modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
-643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd"
+643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd
+"