aboutsummaryrefslogtreecommitdiffstats
path: root/main/fribidi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fribidi/APKBUILD')
-rw-r--r--main/fribidi/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/fribidi/APKBUILD b/main/fribidi/APKBUILD
index 8323819071b..d46978f030e 100644
--- a/main/fribidi/APKBUILD
+++ b/main/fribidi/APKBUILD
@@ -1,16 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fribidi
-pkgver=1.0.11
-pkgrel=1
+pkgver=1.0.13
+pkgrel=0
pkgdesc="Free Implementation of the Unicode Bidirectional Algorithm"
url="https://github.com/fribidi/fribidi"
arch="all"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
makedepends="meson"
subpackages="$pkgname-doc $pkgname-static $pkgname-dev"
source="https://github.com/fribidi/fribidi/releases/download/v$pkgver/fribidi-$pkgver.tar.xz"
# secfixes:
+# 1.0.12-r0:
+# - CVE-2022-25308
+# - CVE-2022-25309
+# - CVE-2022-25310
# 1.0.7-r1:
# - CVE-2019-18397
@@ -18,11 +22,11 @@ build() {
abuild-meson \
-Ddefault_library=both \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -30,5 +34,5 @@ package() {
}
sha512sums="
-6afde86784de06759f18235ccb44f23261a975f7cce0021b16755065a6a8ed84d7d5fb7fdcaadd691b48011efb4bfc2ee67555e5133a294a418cca1a0c85476c fribidi-1.0.11.tar.xz
+09357d842ff9e05b918f826e28e4a25ad996e17f73242ee9ce53fae9f37ec6c639f9cae4271577f6e0269f34265afc893858225c4a94610f0a6ee7580fb1fe07 fribidi-1.0.13.tar.xz
"