aboutsummaryrefslogtreecommitdiffstats
path: root/main/fribidi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fribidi/APKBUILD')
-rw-r--r--main/fribidi/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/main/fribidi/APKBUILD b/main/fribidi/APKBUILD
index 96b36a94468..8323819071b 100644
--- a/main/fribidi/APKBUILD
+++ b/main/fribidi/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fribidi
pkgver=1.0.11
-pkgrel=0
+pkgrel=1
pkgdesc="Free Implementation of the Unicode Bidirectional Algorithm"
url="https://github.com/fribidi/fribidi"
arch="all"
license="LGPL-2.0-or-later"
+makedepends="meson"
subpackages="$pkgname-doc $pkgname-static $pkgname-dev"
source="https://github.com/fribidi/fribidi/releases/download/v$pkgver/fribidi-$pkgver.tar.xz"
@@ -14,20 +15,18 @@ source="https://github.com/fribidi/fribidi/releases/download/v$pkgver/fribidi-$p
# - CVE-2019-18397
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-static
- make
+ abuild-meson \
+ -Ddefault_library=both \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- make check
+ meson test --no-rebuild -v -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="