aboutsummaryrefslogtreecommitdiffstats
path: root/main/fuse3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fuse3/APKBUILD')
-rw-r--r--main/fuse3/APKBUILD77
1 files changed, 42 insertions, 35 deletions
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 99949c9a53f..63b83ae31d4 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -1,38 +1,44 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse3
-_pkgname=fuse
-pkgver=3.9.1
+pkgver=3.16.2
pkgrel=0
-pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
+pkgdesc="Reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
arch="all"
-license="GPL-2.0-only LGPL-2.1-only"
+license="GPL-2.0-only AND LGPL-2.1-only"
depends="fuse-common"
-makedepends="gettext-dev linux-headers meson eudev-dev python3
- py3-six py3-pluggy py3-attrs py3-py"
+makedepends="
+ eudev-dev
+ gettext-dev
+ linux-headers
+ meson
+ "
checkdepends="py3-pytest"
-subpackages="$pkgname-dev $pkgname-doc fuse-common:_common fuse-openrc:_openrc $pkgname-libs"
-source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
- fix-realpath.patch
+subpackages="
+ $pkgname-static
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-libs
+ fuse-common:_common
+ fuse-openrc:_openrc
+ "
+source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.gz
fuse.initd
+ dont-mknod-dev-fuse.patch
"
options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
-
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/fuse-$pkgver
# secfixes:
# 3.2.5-r0:
# - CVE-2018-10906
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
+ -Dinitscriptdir="" \
+ --default-library=both \
. output
- ninja -C output
+ meson compile -C output
}
check() {
@@ -40,29 +46,28 @@ check() {
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
- rm -r "$pkgdir"/dev "$pkgdir"/etc/init.d
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
# create config
install -d "$pkgdir"/etc
- cat >"$pkgdir"/etc/fuse.conf << _EOF_
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
+ cat >"$pkgdir"/etc/fuse.conf <<- _EOF_
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other
-_EOF_
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ _EOF_
}
_common() {
pkgdesc="Common files for fuse2 and fuse3"
- mkdir -p "$subpkgdir"/etc/
- mv "$pkgdir"/etc/fuse.conf "$subpkgdir"/etc/
+
+ amove etc/fuse.conf
}
_openrc() {
@@ -70,6 +75,8 @@ _openrc() {
install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
-sha512sums="295bb62274264789c977a1fee78c6c122a2f227ae85d750b8519cafbdcf6551499b77cf021d83cc8261831e29761c166d84a4e50bdebb4191c76bcad1d15d329 fuse-3.9.1.tar.xz
-1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
-7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"
+sha512sums="
+3e8889863cd67dada67271f095f694dc9e5aaf2561fd1e2285aee95b5a54e692bb195ab8fce57fc2bdf08d0ea17b6d56ca4967b4e4371d639d6133907b2370d3 fuse-3.16.2.tar.gz
+7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd
+9b32a6ba1d1e5fcb7709eaa8e4d5e90fbdd6873ab97b0c651b6d5dda80644a4d1a7c3d1e201929d1f0b13f29422f2cdedf5127832b05d751d0ef83b53870e57a dont-mknod-dev-fuse.patch
+"