aboutsummaryrefslogtreecommitdiffstats
path: root/main/fuse3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fuse3/APKBUILD')
-rw-r--r--main/fuse3/APKBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 56f6dbb129d..63b83ae31d4 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -1,23 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse3
-_pkgname=fuse
-pkgver=3.11.0
+pkgver=3.16.2
pkgrel=0
-pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
+pkgdesc="Reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
arch="all"
-license="GPL-2.0-only LGPL-2.1-only"
+license="GPL-2.0-only AND LGPL-2.1-only"
depends="fuse-common"
makedepends="
eudev-dev
gettext-dev
linux-headers
meson
- py3-attrs
- py3-pluggy
- py3-py
- py3-six
- python3
"
checkdepends="py3-pytest"
subpackages="
@@ -28,21 +22,23 @@ subpackages="
fuse-common:_common
fuse-openrc:_openrc
"
-source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
- fix-realpath.patch
+source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.gz
fuse.initd
+ dont-mknod-dev-fuse.patch
"
options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
-
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/fuse-$pkgver
# secfixes:
# 3.2.5-r0:
# - CVE-2018-10906
build() {
- abuild-meson --default-library=both . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Dinitscriptdir="" \
+ --default-library=both \
+ . output
+ meson compile -C output
}
check() {
@@ -51,7 +47,6 @@ check() {
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
- rm -r "$pkgdir"/dev "$pkgdir"/etc/init.d
install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
# create config
@@ -71,8 +66,8 @@ package() {
_common() {
pkgdesc="Common files for fuse2 and fuse3"
- mkdir -p "$subpkgdir"/etc/
- mv "$pkgdir"/etc/fuse.conf "$subpkgdir"/etc/
+
+ amove etc/fuse.conf
}
_openrc() {
@@ -81,7 +76,7 @@ _openrc() {
}
sha512sums="
-033324de7ea4c7e91fb21c453211c01e53771ec5805c2126e13ef2d4334119a51f5c783b6249e888e28888c753aa04b48ed33cefb6d486d8d526546565f6ae50 fuse-3.11.0.tar.xz
-1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
+3e8889863cd67dada67271f095f694dc9e5aaf2561fd1e2285aee95b5a54e692bb195ab8fce57fc2bdf08d0ea17b6d56ca4967b4e4371d639d6133907b2370d3 fuse-3.16.2.tar.gz
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd
+9b32a6ba1d1e5fcb7709eaa8e4d5e90fbdd6873ab97b0c651b6d5dda80644a4d1a7c3d1e201929d1f0b13f29422f2cdedf5127832b05d751d0ef83b53870e57a dont-mknod-dev-fuse.patch
"