aboutsummaryrefslogtreecommitdiffstats
path: root/main/gamin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gamin/APKBUILD')
-rw-r--r--main/gamin/APKBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
index 5e790d6057e..4030bbe4d41 100644
--- a/main/gamin/APKBUILD
+++ b/main/gamin/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gamin
pkgver=0.1.10
-pkgrel=7
+pkgrel=8
pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
url="http://www.gnome.org/~veillard/gamin"
arch="all"
@@ -9,23 +9,34 @@ license="GPL"
subpackages="$pkgname-dev py-$pkgname:py"
depends=
makedepends="pkgconfig glib-dev python-dev"
-source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz"
+source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
+ fix-deprecated-const.patch"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--disable-static \
--with-threads \
--disable-debug-api \
--disable-debug \
--disable-dnotify \
- --libexecdir=/usr/lib/gamin
+ --libexecdir=/usr/lib/gamin \
+ || return 1
make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
# some kinde of race in the make install which is not solved with -j || return 1
export MKDIRPROG="mkdir -p"
make DESTDIR="$pkgdir" install || return 1
@@ -39,4 +50,5 @@ py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz"
+md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz
+f679aeb48fe9dd376c8828cc9b6941ab fix-deprecated-const.patch"