summaryrefslogtreecommitdiffstats
path: root/main/gamin
diff options
context:
space:
mode:
Diffstat (limited to 'main/gamin')
-rw-r--r--main/gamin/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
new file mode 100644
index 00000000000..730271afb46
--- /dev/null
+++ b/main/gamin/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gamin
+pkgver=0.1.10
+pkgrel=1
+pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
+url="http://www.gnome.org/~veillard/gamin"
+license="GPL"
+subpackages="$pkgname-dev"
+depends=
+makedepends="pkgconfig glib-dev"
+source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-threads \
+ --disable-debug-api \
+ --disable-debug \
+ --disable-dnotify \
+ --libexecdir=/usr/lib/gamin
+ make || return 1
+
+ # some kinde of race in the make install which is not solved with -j
+ export MKDIRPROG="mkdir -p"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz"