aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdbm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gdbm/APKBUILD')
-rw-r--r--main/gdbm/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/gdbm/APKBUILD b/main/gdbm/APKBUILD
index 632bceb5fb9..e5f4b02734c 100644
--- a/main/gdbm/APKBUILD
+++ b/main/gdbm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdbm
pkgver=1.13
-pkgrel=0
+pkgrel=1
pkgdesc="GNU dbm is a set of database routines that use extensible hashing"
url="http://www.gnu.org/software/gdbm/"
arch="all"
@@ -25,15 +25,18 @@ build() {
--enable-libgdbm-compat \
--disable-largefile \
--disable-dependency-tracking \
- --enable-fast-install \
- || return 1
- make || return 1
+ --enable-fast-install
+ make
}
-package() {
+check() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make check
+}
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="fdb777f5b415b0578ea46b4a6fc70151a04a3568e2f2c8c0219ccad8c0d34abb773d80d5d7a06462ad1a3d6c1f3b5b7ab25f9de4f43ccf05c58db05f9a2906ad gdbm-1.13.tar.gz"