aboutsummaryrefslogtreecommitdiffstats
path: root/main/gettext
diff options
context:
space:
mode:
Diffstat (limited to 'main/gettext')
-rw-r--r--main/gettext/APKBUILD14
-rw-r--r--main/gettext/musl-realpath.patch25
2 files changed, 33 insertions, 6 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index 5dfa4e2d19c..7dc5644c9a0 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=gettext
-pkgver=0.20.2
-pkgrel=2
+pkgver=0.21
+pkgrel=0
pkgdesc="GNU locale utilities"
url="https://www.gnu.org/software/gettext/gettext.html"
arch="all"
@@ -12,10 +12,12 @@ license="GPL-3.0-or-later AND LGPL-2.1-or-later AND MIT"
# they depend on gettext and would introduce cyclic dependencies
makedepends="perl ncurses-dev libxml2-dev libunistring-dev"
checkdepends="coreutils"
+subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev
+ $pkgname-lang libintl $pkgname-asprintf $pkgname-libs"
source="https://ftp.gnu.org/gnu/gettext/gettext-$pkgver.tar.xz
skip-tests-musl.patch
- musl-realpath.patch"
-subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang libintl $pkgname-asprintf $pkgname-libs"
+ musl-realpath.patch
+ "
# secfixes:
# 0.20.1-r0:
@@ -65,6 +67,6 @@ asprintf() {
mv "$pkgdir"/usr/lib/libasprintf.so.* "$subpkgdir"/usr/lib
}
-sha512sums="08d20c659004a77e607af17df15f5ce9bd4fc0feca9436aa206b0cbd2516f9f0c98c7ee1faacf7ff429f9b0dd9de219947b300216887a60727602a688acabc82 gettext-0.20.2.tar.xz
+sha512sums="f7e2968651879f8444d43a176a149db9f9411f4a03132a7f3b37c2ed97e3978ae6888169c995c1953cb78943b6e3573811abcbb8661b6631edbbe067b2699ddf gettext-0.21.tar.xz
9fae1898eaf7a871876d2eaeffdf6ab759455bc8062fc232992526d697752d864b6079eb3c1053aea08d3a41892008b201566564fa62275d0ced5cfa6088a4c0 skip-tests-musl.patch
-515ba4034e09ada1ca58e23488387fa7761c7cafb53e31605c82cc826d3cf6ddafbfa1cdea5aca957903695168d0ec6a4db98f82a70858cd0365ec57dfbf04b9 musl-realpath.patch"
+593615f1d3a75e0fff1561b11e6363aacdc44045adf19c765e27360f256149e442643f40ef1ed781d4175e02dd9719871019e16b0c1393a124a8a87ef0cf75b0 musl-realpath.patch"
diff --git a/main/gettext/musl-realpath.patch b/main/gettext/musl-realpath.patch
index 009ebfd95fd..05cb14f7530 100644
--- a/main/gettext/musl-realpath.patch
+++ b/main/gettext/musl-realpath.patch
@@ -1,3 +1,11 @@
+https://gitlab.alpinelinux.org/alpine/aports/-/issues/12295
+
+----
+test-canonicalize.c:339: assertion 'strcmp (result1, "/") == 0' failed
+Aborted (core dumped)
+FAIL test-canonicalize (exit status: 134)
+----
+
diff --git a/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c b/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c
index ff82981..17842e8 100644
--- a/gettext-tools/gnulib-tests/test-canonicalize-lgpl.c
@@ -13,3 +21,20 @@ index ff82981..17842e8 100644
}
else
#endif
+--- a/gettext-tools/gnulib-tests/test-canonicalize.c
++++ b/gettext-tools/gnulib-tests/test-canonicalize.c
+@@ -336,10 +336,10 @@
+ ASSERT (stat ("//", &st2) == 0);
+ if (SAME_INODE (st1, st2))
+ {
+- ASSERT (strcmp (result1, "/") == 0);
+- ASSERT (strcmp (result2, "/") == 0);
+- ASSERT (strcmp (result3, "/") == 0);
+- ASSERT (strcmp (result4, "/") == 0);
++ ASSERT (strcmp (result1, "/") == 0 || strcmp (result1, "//") == 0);
++ ASSERT (strcmp (result2, "/") == 0 || strcmp (result2, "//") == 0);
++ ASSERT (strcmp (result3, "/") == 0 || strcmp (result3, "//") == 0);
++ ASSERT (strcmp (result4, "/") == 0 || strcmp (result4, "//") == 0);
+ }
+ else
+ {