aboutsummaryrefslogtreecommitdiffstats
path: root/main/ghostscript/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/ghostscript/APKBUILD')
-rw-r--r--main/ghostscript/APKBUILD47
1 files changed, 32 insertions, 15 deletions
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index e28d935649a..ab16d6dd42d 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -1,16 +1,29 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=ghostscript
-pkgver=9.54.0
+pkgver=10.02.1
pkgrel=0
-pkgdesc="An interpreter for the PostScript language and for PDF"
+pkgdesc="Interpreter for the PostScript language and for PDF"
url="https://ghostscript.com/"
arch="all"
license="AGPL-3.0-or-later"
options="!check"
-makedepends="autoconf automake libjpeg-turbo-dev libpng-dev expat-dev
- zlib-dev tiff-dev freetype-dev lcms2-dev gtk+3.0-dev
- cups-dev libtool jbig2dec-dev openjpeg-dev"
+makedepends="
+ autoconf
+ automake
+ cups-dev
+ expat-dev
+ freetype-dev
+ gtk+3.0-dev
+ jbig2dec-dev
+ lcms2-dev
+ libjpeg-turbo-dev
+ libpng-dev
+ libtool
+ openjpeg-dev
+ tiff-dev
+ zlib-dev
+ "
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-gtk"
source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver//./}/ghostscript-$pkgver.tar.gz
ghostscript-system-zlib.patch
@@ -18,6 +31,10 @@ source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/
"
# secfixes:
+# 10.02.0-r0:
+# - CVE-2023-43115
+# 9.54-r1:
+# - CVE-2021-3781
# 9.51-r0:
# - CVE-2020-16287
# - CVE-2020-16288
@@ -98,10 +115,11 @@ prepare() {
cd $builddir/ijs
libtoolize --force && aclocal && autoconf && automake --add-missing
- update_config_sub
}
build() {
+ export CFLAGS="$CFLAGS -flto=auto"
+
# build ijs
cd "$builddir"/ijs
./configure \
@@ -109,7 +127,7 @@ build() {
--host=$CHOST \
--prefix=/usr \
--enable-shared \
- --disable-static \
+ --disable-static
make
cd "$builddir"
@@ -123,17 +141,15 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--docdir=/usr/share/doc/"$pkgname" \
- --enable-dynamic \
- --disable-static \
--with-system-libtiff \
--with-ijs \
--with-jbig2dec \
- --without-omni \
+ --without-libpaper \
+ --without-versioned-path \
--enable-gtk \
--with-drivers=ALL \
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
--disable-compile-inits
- make obj/arch.h # workaround parallel build issue
make so all
}
@@ -151,10 +167,11 @@ package() {
gtk() {
pkgdesc="A GTK-enabled PostScript interpreter and renderer"
- install -d "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/gsx "$subpkgdir"/usr/bin/
+ amove usr/bin/gsx
}
-sha512sums="93cfac3a754d4a7fa94112f3e04ba2ae633c40bb924734db72229096aac2f07c95877737f37f2bfef6be1b1d074af79e75cde3d589ea102def7f4654403e4804 ghostscript-9.54.0.tar.gz
+sha512sums="
+24eeff047a24085413283ee42539a2feea4d3de81077664861399055a9d30349a0ef0950746bb0b0ee2237b4b9ee215340204ab0e33347b53dc2acee85fcfc19 ghostscript-10.02.1.tar.gz
70721e3a335afa5e21d4e6cf919119010bd4544a03ab8f53f5325c173902221ad9b88c118b4bfeee80b3e1956bcdbaf4c53f64ae7fb81f5ba57dbc956750c482 ghostscript-system-zlib.patch
-beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch"
+beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch
+"