aboutsummaryrefslogtreecommitdiffstats
path: root/main/glu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/glu/APKBUILD')
-rw-r--r--main/glu/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/main/glu/APKBUILD b/main/glu/APKBUILD
index f76bb5ec5bd..d746752097b 100644
--- a/main/glu/APKBUILD
+++ b/main/glu/APKBUILD
@@ -1,24 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glu
-pkgver=9.0.2
-pkgrel=1
+pkgver=9.0.3
+pkgrel=3
pkgdesc="Mesa OpenGL Utility library"
url="https://cgit.freedesktop.org/mesa/glu/"
arch="all"
options="!check" # No test suite.
license="SGI-B-1.1 AND SGI-B-2.0"
depends_dev="mesa-dev"
-makedepends="$depends_dev cmake meson"
+makedepends="$depends_dev meson"
replaces="mesa-glu"
subpackages="$pkgname-dev"
source="https://mesa.freedesktop.org/archive/glu/glu-$pkgver.tar.xz"
build() {
abuild-meson \
- -D default_library=shared \
- -D gl_provider=osmesa \
+ -Db_lto=true \
+ -Ddefault_library=shared \
+ -Dgl_provider=osmesa \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
@@ -26,5 +27,5 @@ package() {
}
sha512sums="
-2517d7406bb643d12c017a95dcb5d8716f307344332638bcbdf274a90752a7c22165d34745f1b082ed916bb07d40e62d1d1d67d96426225be63166f3480d6f64 glu-9.0.2.tar.xz
+b2781059c0e176192c3fc0d7244645020937a463311171efddb9f35fb94ee43faabcf627fa7f429d48fceaf6dd9c5adb69c86c7a21ec4ea490f4ab143d52e3ba glu-9.0.3.tar.xz
"