aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch')
-rw-r--r--main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch b/main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch
index 644b8a52837..35ab352c072 100644
--- a/main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch
+++ b/main/gnupg/0110-avoid-simple-memory-dumps-via-ptrace.patch
@@ -24,10 +24,10 @@ Upstream bug: https://dev.gnupg.org/T1211
Patch-Source: https://sources.debian.org/data/main/g/gnupg2/2.2.27-2/debian/patches/block-ptrace-on-secret-daemons/Avoid-simple-memory-dumps-via-ptrace.patch
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
-index b167c34..5afcf11 100644
+index 412eb43..1de989b 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
-@@ -50,6 +50,9 @@
+@@ -48,6 +48,9 @@
# include <signal.h>
#endif
#include <npth.h>
@@ -37,7 +37,7 @@ index b167c34..5afcf11 100644
#define INCLUDED_BY_MAIN_MODULE 1
#define GNUPG_COMMON_NEED_AFLOCAL
-@@ -1030,6 +1033,11 @@ main (int argc, char **argv )
+@@ -1095,6 +1098,11 @@ main (int argc, char **argv)
early_system_init ();
@@ -50,10 +50,10 @@ index b167c34..5afcf11 100644
file descriptors and the signal mask. This info is required to
do the exec call properly. We don't need it on Windows. */
diff --git a/configure.ac b/configure.ac
-index 7a2d410..2d8b050 100644
+index 099c6a8..4c9fcee 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1426,7 +1426,7 @@ AC_CHECK_FUNCS([atexit canonicalize_file_name clock_gettime ctermid \
+@@ -1419,7 +1419,7 @@ AC_CHECK_FUNCS([atexit canonicalize_file_name clock_gettime ctermid \
ftruncate funlockfile getaddrinfo getenv getpagesize \
getpwnam getpwuid getrlimit getrusage gettimeofday \
gmtime_r inet_ntop inet_pton isascii lstat memicmp \
@@ -63,7 +63,7 @@ index 7a2d410..2d8b050 100644
stat stpcpy strcasecmp strerror strftime stricmp \
strlwr strncasecmp strpbrk strsep strtol strtoul \
diff --git a/scd/scdaemon.c b/scd/scdaemon.c
-index 5c519f8..cab66a0 100644
+index e43769f..2066543 100644
--- a/scd/scdaemon.c
+++ b/scd/scdaemon.c
@@ -37,6 +37,9 @@
@@ -76,8 +76,8 @@ index 5c519f8..cab66a0 100644
#define INCLUDED_BY_MAIN_MODULE 1
#define GNUPG_COMMON_NEED_AFLOCAL
-@@ -446,6 +449,12 @@ main (int argc, char **argv )
- npth_t pipecon_handler;
+@@ -462,6 +465,12 @@ main (int argc, char **argv )
+ const char *application_priority = NULL;
early_system_init ();
+
@@ -86,6 +86,6 @@ index 5c519f8..cab66a0 100644
+ prctl(PR_SET_DUMPABLE, 0);
+#endif
+
- set_strusage (my_strusage);
+ gpgrt_set_strusage (my_strusage);
gcry_control (GCRYCTL_SUSPEND_SECMEM_WARN);
/* Please note that we may running SUID(ROOT), so be very CAREFUL