aboutsummaryrefslogtreecommitdiffstats
path: root/main/gobject-introspection/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gobject-introspection/APKBUILD')
-rw-r--r--main/gobject-introspection/APKBUILD52
1 files changed, 34 insertions, 18 deletions
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index a99a5353878..b154d28e675 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -1,29 +1,49 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gobject-introspection
-pkgver=1.70.0
-pkgrel=1
+pkgver=1.80.1
+pkgrel=2
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
arch="all"
license="LGPL-2.0-or-later AND GPL-2.0-or-later AND MIT"
-depends_dev="python3 cairo-dev libtool"
-makedepends="$depends_dev glib-dev libffi-dev flex bison python3-dev meson"
+depends_dev="
+ cairo-dev
+ libtool
+ py3-setuptools
+ python3
+ "
+makedepends="$depends_dev
+ bison
+ flex
+ glib-dev
+ libffi-dev
+ meson
+ python3-dev
+ "
subpackages="$pkgname-doc $pkgname-dev"
replaces="libgirepository"
checkdepends="sed"
-source="https://download.gnome.org/sources/gobject-introspection/${pkgver%.*}/gobject-introspection-$pkgver.tar.xz
- musl-time64.patch
- "
+source="https://download.gnome.org/sources/gobject-introspection/${pkgver%.*}/gobject-introspection-$pkgver.tar.xz"
+
+case "$CARCH" in
+*)
+ # FIXME: the gir scan on
+ #define REGRESS_GOOD_EXPR_CONSTANT (1 + 2 * (3 + 2) << 3 - 4 >> REGRESS_ATEST_ERROR_CODE2)
+ # evaluates to 0 instead of -2305843009213693952
+ # so a test failes
+ # https://gitlab.gnome.org/GNOME/gobject-introspection/-/issues/458
+ options="$options !check"
+ ;;
+esac
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -31,15 +51,11 @@ package() {
}
dev() {
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/share "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib/gobject-introspection "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+ amove usr/bin usr/share usr/lib/gobject-introspection
default_dev
replaces="gobject-introspection"
}
sha512sums="
-216b376ed423f607e36c723dd6b67975dbfb63c253f2d8bd0b3661e3d69f8c8059cf221db8c5260b0262fad1b7d738f3b2e5fbd51fdbc31e40ccb115c209baf0 gobject-introspection-1.70.0.tar.xz
-a55df8fbb8d27d073bbab7e3bd2ca5e272c3fca2a3e144207d4cac06dd90f51443373b077fa64543887e2d5da4bc017bd5245473b83dd0ed551a5a437eec9241 musl-time64.patch
+f45c2c1b105086488d974c6134db9910746df8edb187772f2ecd249656a1047c8ac88ba51f5bf7393c3d99c3ace143ecd09be256c2f4d0ceee110c9ad51a839a gobject-introspection-1.80.1.tar.xz
"