aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphene/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/graphene/APKBUILD')
-rw-r--r--main/graphene/APKBUILD34
1 files changed, 25 insertions, 9 deletions
diff --git a/main/graphene/APKBUILD b/main/graphene/APKBUILD
index ddd0dfc56ab..3c04d0fdd09 100644
--- a/main/graphene/APKBUILD
+++ b/main/graphene/APKBUILD
@@ -1,31 +1,47 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=graphene
-pkgver=1.10.6
-pkgrel=1
+pkgver=1.10.8
+pkgrel=4
pkgdesc="A thin layer of graphic data types"
url="http://ebassi.github.io/graphene/"
arch="all"
license="MIT"
makedepends="meson glib-dev gobject-introspection-dev"
+checkdepends="py3-gobject3"
subpackages="$pkgname-dev"
-source="https://github.com/ebassi/graphene/releases/download/$pkgver/graphene-$pkgver.tar.xz
- fix-gnome-shell-touch-issues.patch"
+source="https://github.com/ebassi/graphene/archive/$pkgver/graphene-$pkgver.tar.gz
+ 0001-meson-don-t-install-introspection-file-with-installe.patch
+ "
build() {
+ case "$CARCH" in
+ arm*)
+ # XXX: https://github.com/ebassi/graphene/issues/215
+ # neon quite broken on arm 32-bit
+ _neon=false
+ ;;
+ *)
+ _neon=true
+ ;;
+ esac
abuild-meson \
+ -Db_lto=true \
+ -Darm_neon=$_neon \
-Dinstalled_tests=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72 graphene-1.10.6.tar.xz
-07f2e9ed7099f1e3f785f7b53078e4ea642739bfb23f4c3353c42d72690df3368fac28d70197eb28dbf02ddd1832d89e41ea83c1591d54a57fccafa3e9b4bedc fix-gnome-shell-touch-issues.patch"
+sha512sums="
+526b0c17049459b687ceb7f6c26c9d982535e4048e74a0b6282704f9811d3c2e7e0e6cfef166aa953306b6cf77add6677bc600ae0c66cc052dc04c3d0345bd68 graphene-1.10.8.tar.gz
+ce7e9f13821c1f0f4a9b3ae8e744c8418ca516af21417b666ed6f52db623b1214c40180a0d3a00e47a628758dabc2399b627b02fa758e4ddcf0a7e485c360f5b 0001-meson-don-t-install-introspection-file-with-installe.patch
+"