aboutsummaryrefslogtreecommitdiffstats
path: root/main/grep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/grep/APKBUILD')
-rw-r--r--main/grep/APKBUILD26
1 files changed, 8 insertions, 18 deletions
diff --git a/main/grep/APKBUILD b/main/grep/APKBUILD
index d60a66f98ce..d58d5bbc59b 100644
--- a/main/grep/APKBUILD
+++ b/main/grep/APKBUILD
@@ -1,27 +1,19 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=grep
-pkgver=3.7
+pkgver=3.11
pkgrel=0
pkgdesc="Searches input files for lines containing a match to a specified pattern"
url="https://www.gnu.org/software/grep/grep.html"
arch="all"
license="GPL-3.0-or-later"
-makedepends="pcre-dev autoconf automake"
+makedepends="pcre2-dev autoconf automake"
checkdepends="coreutils bash diffutils"
subpackages="$pkgname-doc"
-source="https://mirrors.kernel.org/gnu/grep/grep-$pkgver.tar.xz
- fix-tests.patch"
-# for whatever reason, all the builders locked up in the testsuite. investigate later.
-options="!check"
-
-prepare() {
- default_prepare
- sed -i '/test-localename$(EXEEXT)/d' \
- "$builddir"/gnulib-tests/Makefile.in
-}
+source="https://mirrors.kernel.org/gnu/grep/grep-$pkgver.tar.xz"
build() {
+ CFLAGS="$CFLAGS -flto=auto"\
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,17 +27,15 @@ build() {
}
check() {
- make -C "$builddir" check
+ make check || {
+ cat tests/test-suite.log
+ }
}
package() {
make DESTDIR="$pkgdir" install
-
- rm -rf "$pkgdir"/usr/lib/charset.alias
- rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
sha512sums="
-e9e45dcd40af8367f819f2b93c5e1b4e98a251a9aa251841fa67a875380fae52cfa27c68c6dbdd6a4dde1b1017ee0f6b9833ef6dd6e419d32d71b6df5e972b82 grep-3.7.tar.xz
-9ba6b01c0c74933299afb469dadd2ea0c7e24befa34c691671a576063e32a1f0c735541e5e2bb0073d8afd814790909f7f895827aa8a2fbacdfcae380a7bcb11 fix-tests.patch
+f254a1905a08c8173e12fbdd4fd8baed9a200217fba9d7641f0d78e4e002c1f2a621152d67027d9b25f0bb2430898f5233dc70909d8464fd13d7dd9298e65c42 grep-3.11.tar.xz
"