aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-base/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gst-plugins-base/APKBUILD')
-rw-r--r--main/gst-plugins-base/APKBUILD45
1 files changed, 34 insertions, 11 deletions
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index b5ccc5a8856..df1b3823208 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -1,23 +1,42 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-base
-pkgver=1.18.4
+pkgver=1.22.11
pkgrel=0
pkgdesc="GStreamer streaming media framework base plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
-license="GPL-2.0-or-later LGPL-2.0-or-later"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
replaces="gst-plugins-base1 gst-plugins-bad"
depends_dev="wayland-dev"
-makedepends="alsa-lib-dev cdparanoia-dev expat-dev glib-dev
- gobject-introspection-dev gstreamer-dev gtk+3.0-dev libice-dev
- libogg-dev libsm-dev libtheora-dev libvorbis-dev libxv-dev mesa-dev
- meson opus-dev orc-compiler orc-dev perl"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz
- meson-0.58.patch"
+makedepends="
+ alsa-lib-dev
+ cdparanoia-dev
+ expat-dev
+ glib-dev
+ gobject-introspection-dev
+ graphene-dev
+ gstreamer-dev
+ gtk+3.0-dev
+ libice-dev
+ libogg-dev
+ libsm-dev
+ libtheora-dev
+ libvorbis-dev
+ libxv-dev
+ mesa-dev
+ meson
+ opus-dev
+ orc-compiler
+ orc-dev
+ perl
+ "
+source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-1.0"
# secfixes:
+# 1.18.4-r0:
+# - CVE-2021-3522
# 1.16.0-r0:
# - CVE-2019-9928
@@ -26,13 +45,18 @@ ldpath="/usr/lib/gstreamer-1.0"
options="!check"
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dalsa=enabled \
-Dintrospection=enabled \
-Dpackage-origin="https://alpinelinux.org" \
-Dpackage-name="GStreamer base plug-ins (Alpine Linux)" \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -49,6 +73,5 @@ doc() {
}
sha512sums="
-c750d68404462807ff03f441e232c4d98752a9bceeec3038fb37a105942f25499bde0660ca688b6f3204c58eb6a2e3f33671e979018c8bd829e7591455961a6a gst-plugins-base-1.18.4.tar.xz
-6cbb14bb97f1eea324b9adb59f0fa025757bc3eabb6310beae20f660b094d1d1a0f0757623fa3649fe28aea8137df9444506bbe18198e5aebeca96366db4da77 meson-0.58.patch
+cfd8f7fe66f4707e043c8f070110eb80f9804cec529c8d29b13dbc8604db90e3f010c9614d538ad076b826df54f75ce5ebac355bd05a874e44dccead6a953c60 gst-plugins-base-1.22.11.tar.xz
"