aboutsummaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-base/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gst-plugins-base/APKBUILD')
-rw-r--r--main/gst-plugins-base/APKBUILD41
1 files changed, 33 insertions, 8 deletions
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index 74666f36809..27d8aefa62e 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -1,22 +1,42 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-base
-pkgver=1.18.5
+pkgver=1.22.8
pkgrel=0
pkgdesc="GStreamer streaming media framework base plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
-license="GPL-2.0-or-later LGPL-2.0-or-later"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
replaces="gst-plugins-base1 gst-plugins-bad"
depends_dev="wayland-dev"
-makedepends="alsa-lib-dev cdparanoia-dev expat-dev glib-dev
- gobject-introspection-dev graphene-dev gstreamer-dev gtk+3.0-dev libice-dev
- libogg-dev libsm-dev libtheora-dev libvorbis-dev libxv-dev mesa-dev
- meson opus-dev orc-compiler orc-dev perl"
+makedepends="
+ alsa-lib-dev
+ cdparanoia-dev
+ expat-dev
+ glib-dev
+ gobject-introspection-dev
+ graphene-dev
+ gstreamer-dev
+ gtk+3.0-dev
+ libice-dev
+ libogg-dev
+ libsm-dev
+ libtheora-dev
+ libvorbis-dev
+ libxv-dev
+ mesa-dev
+ meson
+ opus-dev
+ orc-compiler
+ orc-dev
+ perl
+ "
source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-1.0"
# secfixes:
+# 1.18.4-r0:
+# - CVE-2021-3522
# 1.16.0-r0:
# - CVE-2019-9928
@@ -25,13 +45,18 @@ ldpath="/usr/lib/gstreamer-1.0"
options="!check"
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dalsa=enabled \
-Dintrospection=enabled \
-Dpackage-origin="https://alpinelinux.org" \
-Dpackage-name="GStreamer base plug-ins (Alpine Linux)" \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -48,5 +73,5 @@ doc() {
}
sha512sums="
-b336cf3a3a5357429f3ae2bcfa9e4c367646360a1d7a74f8f2458703d232b5a5f6dcf865ba27a15c7e8e1e1cbde08b8c345104f792d16232f5833f52767a08b4 gst-plugins-base-1.18.5.tar.xz
+3663887ebcde060792f242970d30b5499782745b272b64a9577ab58fd7ee8414d1218780ad18b7f436074bd7ef959653d43a2356c2a9e8ebad4d35bbc1d90604 gst-plugins-base-1.22.8.tar.xz
"