aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk-vnc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk-vnc/APKBUILD')
-rw-r--r--main/gtk-vnc/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/gtk-vnc/APKBUILD b/main/gtk-vnc/APKBUILD
new file mode 100644
index 00000000000..dd94fd54bc4
--- /dev/null
+++ b/main/gtk-vnc/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-vnc
+pkgver=0.3.10
+pkgrel=0
+pkgdesc="A VNC viewer widget for GTK"
+url="http://live.gnome.org/gtk-vnc"
+license="LGPL"
+subpackages="$pkgname-dev gvncviewer"
+makedepends="gnutls-dev gtk+-dev libiconv-dev gettext-dev intltool expat-dev
+ libgcrypt-dev libgpg-error-dev cyrus-sasl-dev"
+depends_dev="gtk+-dev gnutls-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/0.3/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --without-python \
+ --with-examples \
+ --disable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+gvncviewer() {
+ pkgdesc="Demo application for gtk-vnc"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="9aa9d830b219255c8d6753ef55802932 gtk-vnc-0.3.10.tar.bz2"