aboutsummaryrefslogtreecommitdiffstats
path: root/main/gummiboot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gummiboot/APKBUILD')
-rw-r--r--main/gummiboot/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/main/gummiboot/APKBUILD b/main/gummiboot/APKBUILD
index 22b5c55d348..f6a50f56e74 100644
--- a/main/gummiboot/APKBUILD
+++ b/main/gummiboot/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gummiboot
pkgver=48.1
-pkgrel=1
+pkgrel=7
pkgdesc="Simple EFI Boot Manager"
-url="http://freedesktop.org/wiki/Software/gummiboot"
-arch="x86 x86_64"
+url="https://cgit.freedesktop.org/gummiboot/"
+arch="x86 x86_64 aarch64"
license="LGPL-2.0-or-later"
depends="$pkgname-efistub=$pkgver-r$pkgrel"
makedepends="util-linux-dev gnu-efi-dev autoconf automake docbook-xsl libxslt"
@@ -15,6 +15,7 @@ source="https://dev.alpinelinux.org/archive/gummiboot/gummiboot-$pkgver.tar.gz
sysmacros.patch
remove-conflicts.patch
"
+options="!check"
prepare() {
default_prepare
@@ -26,7 +27,10 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr
- make -j1 EFI_CFLAGS="$CFLAGS -std=gnu89"
+ # new gnu-efi has stddef.h include which relies on it coming from syste.,
+ # this uses -nostdinc and doesn't add it. these cflags come last, so it still
+ # shouldn't shadow the efi incdir.
+ make -j1 EFI_CFLAGS="$CFLAGS -I/usr/include -std=gnu89"
}
package() {
@@ -35,6 +39,10 @@ package() {
efistub() {
pkgdesc="Linux UEFI stub from the gummiboot project"
+ depends=
+ provides="efistub"
+ provider_priority=100 # highest
+
amove usr/lib/gummiboot/*.efi.stub
}