aboutsummaryrefslogtreecommitdiffstats
path: root/main/gummiboot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gummiboot/APKBUILD')
-rw-r--r--main/gummiboot/APKBUILD51
1 files changed, 30 insertions, 21 deletions
diff --git a/main/gummiboot/APKBUILD b/main/gummiboot/APKBUILD
index bebecb50928..f6a50f56e74 100644
--- a/main/gummiboot/APKBUILD
+++ b/main/gummiboot/APKBUILD
@@ -1,45 +1,54 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gummiboot
pkgver=48.1
-pkgrel=0
+pkgrel=7
pkgdesc="Simple EFI Boot Manager"
-url="http://freedesktop.org/wiki/Software/gummiboot"
-arch="x86 x86_64"
+url="https://cgit.freedesktop.org/gummiboot/"
+arch="x86 x86_64 aarch64"
license="LGPL-2.0-or-later"
-depends=""
-depends_dev="util-linux-dev"
-makedepends="$depends_dev gnu-efi-dev autoconf automake docbook-xsl libxslt"
-install=""
-subpackages="$pkgname-doc"
+depends="$pkgname-efistub=$pkgver-r$pkgrel"
+makedepends="util-linux-dev gnu-efi-dev autoconf automake docbook-xsl libxslt"
+subpackages="$pkgname-doc $pkgname-efistub"
#source="https://cgit.freedesktop.org/gummiboot/snapshot/gummiboot-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/gummiboot/gummiboot-$pkgver.tar.gz
gummiboot-aarch64-support.patch
sysmacros.patch
+ remove-conflicts.patch
"
-
-builddir="$srcdir"/gummiboot-$pkgver
+options="!check"
prepare() {
- cd "$builddir"
- default_prepare || return 1
- ./autogen.sh || return 1
+ default_prepare
+ ./autogen.sh
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make -j1 EFI_CFLAGS="$CFLAGS -std=gnu89"
+ --prefix=/usr
+ # new gnu-efi has stddef.h include which relies on it coming from syste.,
+ # this uses -nostdinc and doesn't add it. these cflags come last, so it still
+ # shouldn't shadow the efi incdir.
+ make -j1 EFI_CFLAGS="$CFLAGS -I/usr/include -std=gnu89"
}
package() {
- cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
+ make install DESTDIR="$pkgdir"
+}
+
+efistub() {
+ pkgdesc="Linux UEFI stub from the gummiboot project"
+ depends=
+ provides="efistub"
+ provider_priority=100 # highest
+
+ amove usr/lib/gummiboot/*.efi.stub
}
-sha512sums="a536db10ee384fa2cd38d22bd43f87215501c38471612a1d30986748d645d970e67b3f3d38fc9d6b53fe8532ec18283690f88d77b056dd737db5efb50bf63293 gummiboot-48.1.tar.gz
+sha512sums="
+a536db10ee384fa2cd38d22bd43f87215501c38471612a1d30986748d645d970e67b3f3d38fc9d6b53fe8532ec18283690f88d77b056dd737db5efb50bf63293 gummiboot-48.1.tar.gz
6acc971c59b917616d75f5935859d109efff14c55b8fb26075ee89b6e4141f1c91708c1fc77f0acb2239d9030f4b350eaf1dac59ebb37e7a9ae5682eb52687cf gummiboot-aarch64-support.patch
-b16d5f68429acfd7ff7942ef6091455035645cb592b9f4b1424daff3245c584bf61c30a7d5eb236530c46226d67ba48f6496f6ae00de6c94a7c5e37f5bdc4831 sysmacros.patch"
+b16d5f68429acfd7ff7942ef6091455035645cb592b9f4b1424daff3245c584bf61c30a7d5eb236530c46226d67ba48f6496f6ae00de6c94a7c5e37f5bdc4831 sysmacros.patch
+2f48957253afdb05d1ec401a80383bc582543822fda2c2a30b8a9137481b6911194ac34c7da323414dd00234cd51b8f7803788360e747d325e192b71f9171f72 remove-conflicts.patch
+"