aboutsummaryrefslogtreecommitdiffstats
path: root/main/hostapd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/hostapd/APKBUILD')
-rw-r--r--main/hostapd/APKBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/main/hostapd/APKBUILD b/main/hostapd/APKBUILD
index 2ac593fbecc..28bc83d0e63 100644
--- a/main/hostapd/APKBUILD
+++ b/main/hostapd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hostapd
pkgver=2.7
-pkgrel=5
+pkgrel=6
pkgdesc="daemon for wireless software access points"
url="http://hostap.epitest.fi/hostapd/"
arch="all"
@@ -36,15 +36,21 @@ patches="CVE-2012-4445.patch
0024-SAE-Reject-unsuitable-groups-based-on-REVmd-changes.patch
0025-dragonfly-Disable-use-of-groups-using-Brainpool-curv.patch
CVE-2019-16275.patch
- "
-source="http://hostap.epitest.fi/releases/$pkgname-$pkgver.tar.gz
+ 0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+ 0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+ 0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
+"
+source="https://w1.fi/releases/$pkgname-$pkgver.tar.gz
$patches
$pkgname.initd
- $pkgname.confd"
+ $pkgname.confd
+ "
options="!check" #no testsuite
builddir="$srcdir"/$pkgname-$pkgver/hostapd
# secfixes:
+# 2.7-r6:
+# - CVE-2020-12695
# 2.7-r5:
# - CVE-2019-16275
# 2.7-r4:
@@ -53,8 +59,6 @@ builddir="$srcdir"/$pkgname-$pkgver/hostapd
# - CVE-2019-9496
# 2.7-r1:
# - CVE-2019-11555
-# 2.7-r0:
-# - CVE-2017-13082
# 2.6-r2:
# - CVE-2017-13077
# - CVE-2017-13078
@@ -69,10 +73,14 @@ builddir="$srcdir"/$pkgname-$pkgver/hostapd
prepare() {
local conf="$builddir/.config"
+ # This is required because our builddir is the hostapd/ directory
+ # inside the extracted archive, while patches mostly apply against
+ # the src/ directory that is in the same directory as the hostapd/
+ # one is
cd "$builddir"/..
- for i in $patches; do
- msg $i
- patch -p1 -i "$srcdir"/$i
+ for i in "$srcdir"/*.patch; do
+ msg "Applying $i..."
+ patch -p1 -i $i
done
cd "$builddir"
@@ -153,5 +161,8 @@ bcae73930c35d441c5615970c305abb3dff293fdec16df50823e57419b22d1aac0e780970619e0c7
da5f4248a0173cd7d07972b760631a8dc26f258e7b5be059c0d7de26e17f668945a62d2afce01ed1a1e9df6c55f9fd6ee344d4f006f5564b90a25e90e1e7c704 0024-SAE-Reject-unsuitable-groups-based-on-REVmd-changes.patch
4734a8ab8ba1e91fc9e3d729f34527c14c291df238b02adea5acc04b0361b41d4bffca2fb13a4f464e9f007fa624117af4f50d755cb41a3129b4868da91bdf9a 0025-dragonfly-Disable-use-of-groups-using-Brainpool-curv.patch
63710cfb0992f2c346a9807d8c97cbeaed032fa376a0e93a2e56f7742ce515e9c4dfadbdb1af03ba272281f639aab832f0178f67634c222a5d99e1d462aa9e38 CVE-2019-16275.patch
+b76bbca282a74ef16c0303e5dbd2ccd33a62461595964d52c1481b0bfa4f41deacde56830b85409b288803b87ceb6f33cf0ccc69c5b17ec632c2d4784b872f3c 0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+00cc739e78c42353a555c0de2f29defecff372927040e14407a231d1ead7ff32a37c9fd46bea7cdf1c24e3ac891bc3d483800d44fc6d2c8a12d2ae886523b12c 0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+69243af20cdcfa837c51917a3723779f4825e11436fb83311355b4ffe8f7a4b7a5747a976f7bf923038c410c9e9055b13b866d9a396913ad08bdec3a70e9f6e0 0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
b54b7c6aa17e5cb86a9b354a516eb2dbefb544df18471339c61d82776de447011a2ac290bea1e6c8beae4b6cebefafb8174683ea42fb773e9e8fe6c679f33ba3 hostapd.initd
0882263bbd7c0b05bf51f51d66e11a23a0b8ca7da2a3b8a30166d2c5f044c0c134e6bccb1d02c9e81819ca8fb0c0fb55c7121a08fe7233ccaa73ff8ab9a238fe hostapd.confd"