aboutsummaryrefslogtreecommitdiffstats
path: root/main/hunspell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/hunspell/APKBUILD')
-rw-r--r--main/hunspell/APKBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index e7862047638..e676907c932 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -1,29 +1,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hunspell
-pkgver=1.7.0
-pkgrel=1
+pkgver=1.7.2
+pkgrel=4
pkgdesc="Spell checker and morphological analyzer library and program"
url="https://hunspell.github.io/"
arch="all"
-license="GPL-2.0-or-later LGPL-2.0-or-later MPL-1.1"
+license="GPL-2.0-or-later OR LGPL-2.1-or-later OR MPL-1.1"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang lib$pkgname:libs"
-makedepends="gettext-dev ncurses-dev readline-dev autoconf automake libtool"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v$pkgver.tar.gz
- CVE-2019-16707.patch
- "
+makedepends="gettext-dev ncurses-dev readline-dev"
+checkdepends="bash"
+source="https://github.com/hunspell/hunspell/releases/download/v$pkgver/hunspell-$pkgver.tar.gz"
# secfixes:
# 1.7.0-r1:
# - CVE-2019-16707
prepare() {
- cd "$builddir"
- default_prepare
- autoreconf -vif
+ default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,14 +34,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}
-sha512sums="8149b2e8b703a0610c9ca5160c2dfad3cf3b85b16b3f0f5cfcb7ebb802473b2d499e8e2d0a637a97a37a24d62424e82d3880809210d3f043fa17a4970d47c903 hunspell-1.7.0.tar.gz
-e7674819a9da4c3d742d34338d68d137d8613f97be2d25bf20db5219d4dd626f59a63ed4757b92f34307f499f2d687014065cdea97b55c98db295a8290300d2d CVE-2019-16707.patch"
+sha512sums="
+49b3619bff12e111b6cc3f3d9463612b116f9b2a976896718e65f5bc4a83ece11100aaf56a4d18127ea39107446c495e12affe5ff3c9159ae8aba70e512f44ac hunspell-1.7.2.tar.gz
+"