aboutsummaryrefslogtreecommitdiffstats
path: root/main/ifupdown
diff options
context:
space:
mode:
Diffstat (limited to 'main/ifupdown')
-rw-r--r--main/ifupdown/APKBUILD36
-rw-r--r--main/ifupdown/busybox-compat.patch40
-rw-r--r--main/ifupdown/ifupdown-alpine-ifstate.patch13
-rw-r--r--main/ifupdown/ifupdown-no-dpkg.patch26
-rw-r--r--main/ifupdown/makefile-arch.patch10
-rw-r--r--main/ifupdown/musl-macros-archlinux.patch13
-rw-r--r--main/ifupdown/musl-macros-main.patch13
7 files changed, 0 insertions, 151 deletions
diff --git a/main/ifupdown/APKBUILD b/main/ifupdown/APKBUILD
deleted file mode 100644
index e63a72ecf7a..00000000000
--- a/main/ifupdown/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=ifupdown
-pkgver=0.8.36
-pkgrel=0
-pkgdesc="high level tools to configure network interfaces"
-url="https://packages.debian.org/ifupdown"
-arch="all"
-license="GPL-2.0-or-later"
-depends="run-parts"
-makedepends="perl"
-source="https://deb.debian.org/debian/pool/main/i/ifupdown/ifupdown_$pkgver.tar.xz
- musl-macros-main.patch
- musl-macros-archlinux.patch
- makefile-arch.patch
- busybox-compat.patch
- ifupdown-alpine-ifstate.patch
- ifupdown-no-dpkg.patch"
-provides="ifupdown-any"
-provider_priority=100
-
-build() {
- make
-}
-
-package() {
- make BASEDIR="$pkgdir" install
-}
-
-sha512sums="a95a819c1b844f63f7f7804aba71a261f93550228ff25bf7e61ec366001eace5bd22dfe71d9f44c461c0b281bc4ea86565afe257a79b28b684eac6615c0bb55a ifupdown_0.8.36.tar.xz
-1de60402dfc2e246c162726093c765971021e7a0069372e0a167f62a9e90ef742f4a5e7593dd9da45f689e806d23e59156754d6bbeed4e1a725d97adb525eac6 musl-macros-main.patch
-a70b947b1b618d838e03f6493f2a9748565b0a077b1d526c6ad7ba7f4d7e8c287c42d92140164f4e7eb2e1860e1d476b3d44b88070e5e6bfe00ab0286db64006 musl-macros-archlinux.patch
-31e436464be33e63c37a914ab77c9a3c0d4b94a1037457e483754bb1c262d4c6a318205a76277f58510a7030b7e69ae6b36ab8a966940771dbe8544a6079915b makefile-arch.patch
-c99209142275b103d978e45037f3dcf0dcc4a6f33cf480e582e48d9c7858b7873012f287c2894376c841610842046b4e5b7da58632f839ab526e33704f758e5d busybox-compat.patch
-422998dae8d0ac6049064c93c22baea143eefa7cab9a330b41ec6e317294da4976c193a7a252a8b4a3a47b93ebb01ef308f5a3803838d6452fc283a159ad1e89 ifupdown-alpine-ifstate.patch
-dfda752c68fd71d016f770753fa7142179dcb2c6f92cc78a9efa8135897e8186c549062bb1631c50c6087725e796c62e900d3f3a91e52d8c436be64a18efbfba ifupdown-no-dpkg.patch"
diff --git a/main/ifupdown/busybox-compat.patch b/main/ifupdown/busybox-compat.patch
deleted file mode 100644
index 706b5040060..00000000000
--- a/main/ifupdown/busybox-compat.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/main.c 2019-01-28 18:21:37.000000000 +0100
-+++ b/main.c 2019-06-01 19:22:23.224959630 +0200
-@@ -94,8 +94,8 @@
- "\t--no-loopback don't act specially on the loopback device\n");
-
- if (!(cmds == iface_list) && !(cmds == iface_query))
-- printf( "\t--force force de/configuration\n"
-- "\t--ignore-errors ignore errors\n");
-+ printf("\t-f,--force\t\t\tforce de/configuration\n"
-+ "\t--ignore-errors\t\t\tignore errors\n");
-
- if ((cmds == iface_list) || (cmds == iface_query))
- printf( "\t--list list all matching known interfaces\n"
-@@ -439,7 +439,7 @@
- {"no-mappings", no_argument, NULL, 1},
- {"no-scripts", no_argument, NULL, 4},
- {"no-loopback", no_argument, NULL, 5},
-- {"force", no_argument, NULL, 2},
-+ {"force", no_argument, NULL, 'f'},
- {"ignore-errors", no_argument, NULL, 7},
- {"option", required_argument, NULL, 'o'},
- {"list", no_argument, NULL, 'l'},
-@@ -450,7 +450,7 @@
- };
-
- for (;;) {
-- int c = getopt_long(*argc, *argv, "X:s:i:o:hVvnal", long_opts, NULL);
-+ int c = getopt_long(*argc, *argv, "X:s:i:o:hVvnalf", long_opts, NULL);
-
- if (c == EOF)
- break;
-@@ -526,7 +526,7 @@
- run_mappings = false;
- break;
-
-- case 2: /* --force */
-+ case 'f': /* --force */
- if ((cmds == iface_list) || (cmds == iface_query))
- usage();
- force = true;
diff --git a/main/ifupdown/ifupdown-alpine-ifstate.patch b/main/ifupdown/ifupdown-alpine-ifstate.patch
deleted file mode 100644
index fd76da91b2c..00000000000
--- a/main/ifupdown/ifupdown-alpine-ifstate.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/header.h b/header.h
-index b621448..a735176 100644
---- a/header.h
-+++ b/header.h
-@@ -97,7 +97,7 @@ struct mapping_defn
- #define MAX_VARNAME 32
- #define EUNBALPER 10000
- #ifndef RUN_DIR
--#define RUN_DIR "/run/network/"
-+#define RUN_DIR "/var/run/"
- #endif
-
- #ifndef LO_IFACE
diff --git a/main/ifupdown/ifupdown-no-dpkg.patch b/main/ifupdown/ifupdown-no-dpkg.patch
deleted file mode 100644
index 4cb9268123b..00000000000
--- a/main/ifupdown/ifupdown-no-dpkg.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/defn2c.pl b/defn2c.pl
-index c449de2..ef8d475 100755
---- a/defn2c.pl
-+++ b/defn2c.pl
-@@ -2,7 +2,7 @@
-
- use strict;
-
--my $DEB_HOST_ARCH_OS = `dpkg-architecture -qDEB_HOST_ARCH_OS`;
-+my $DEB_HOST_ARCH_OS = `uname -s|tr [A-Z] [a-z]`;
-
- $DEB_HOST_ARCH_OS =~ s/\n//;
-
-diff --git a/defn2man.pl b/defn2man.pl
-index 6ddcfdd..f1e6bde 100755
---- a/defn2man.pl
-+++ b/defn2man.pl
-@@ -2,7 +2,7 @@
-
- use strict;
-
--my $DEB_HOST_ARCH_OS = `dpkg-architecture -qDEB_HOST_ARCH_OS`;
-+my $DEB_HOST_ARCH_OS = `uname -s | tr [A-Z] [a-z]`;
-
- $DEB_HOST_ARCH_OS =~ s/\n//;
-
diff --git a/main/ifupdown/makefile-arch.patch b/main/ifupdown/makefile-arch.patch
deleted file mode 100644
index 8a856d1f2d7..00000000000
--- a/main/ifupdown/makefile-arch.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/Makefile 2019-01-28 18:25:51.000000000 +0100
-+++ b/Makefile 2019-06-01 19:10:28.644361881 +0200
-@@ -1,6 +1,6 @@
- VERSION ?= 0.8
- CFLAGS ?= -Wall -W -Wno-unused-parameter -g -O2
--ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-+ARCH := linux
-
- BASEDIR ?= $(DESTDIR)
-
diff --git a/main/ifupdown/musl-macros-archlinux.patch b/main/ifupdown/musl-macros-archlinux.patch
deleted file mode 100644
index e72e6d79ba1..00000000000
--- a/main/ifupdown/musl-macros-archlinux.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/archlinux.c 2018-08-25 16:09:19.000000000 +0200
-+++ b/archlinux.c 2019-06-01 19:02:42.615387535 +0200
-@@ -10,6 +10,10 @@
-
- #include "archcommon.h"
-
-+#ifndef FNM_EXTMATCH
-+#define FNM_EXTMATCH 0
-+#endif
-+
- bool variable_match(const char *iface, const char *variable, const char *pattern) {
- // Map platform-independent variables to sysfs names
- if(!strcasecmp(variable, "mac"))
diff --git a/main/ifupdown/musl-macros-main.patch b/main/ifupdown/musl-macros-main.patch
deleted file mode 100644
index d934f274270..00000000000
--- a/main/ifupdown/musl-macros-main.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/main.c 2019-01-28 18:21:37.000000000 +0100
-+++ b/main.c 2019-06-01 18:59:48.889202981 +0200
-@@ -20,6 +20,10 @@
- #include "archcommon.h"
- #include "header.h"
-
-+#ifndef FNM_EXTMATCH
-+#define FNM_EXTMATCH 0
-+#endif
-+
- static const char *argv0;
- bool do_interface_lock = true;
- bool no_act = false;