aboutsummaryrefslogtreecommitdiffstats
path: root/main/inih/fix-pkgconfig-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/inih/fix-pkgconfig-version.patch')
-rw-r--r--main/inih/fix-pkgconfig-version.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/inih/fix-pkgconfig-version.patch b/main/inih/fix-pkgconfig-version.patch
new file mode 100644
index 00000000000..dbabe24a86a
--- /dev/null
+++ b/main/inih/fix-pkgconfig-version.patch
@@ -0,0 +1,40 @@
+diff --git a/meson.build b/meson.build
+index 4602326..f63a913 100644
+--- a/meson.build
++++ b/meson.build
+@@ -64,7 +64,8 @@ lib_inih = library('inih',
+ include_directories : inc_inih,
+ c_args : arg_static,
+ install : distro_install,
+- soversion : '0'
++ soversion : '0',
++ version: '0'
+ )
+
+ if distro_install
+@@ -73,6 +74,7 @@ if distro_install
+ pkg.generate(lib_inih,
+ name : 'inih',
+ description : 'simple .INI file parser',
++ version : '0'
+ )
+ endif
+
+@@ -90,7 +92,8 @@ if get_option('with_INIReader')
+ include_directories : inc_INIReader,
+ dependencies : inih_dep,
+ install : distro_install,
+- soversion : '0'
++ soversion : '0',
++ version: '0'
+ )
+
+ if distro_install
+@@ -99,6 +102,7 @@ if get_option('with_INIReader')
+ pkg.generate(lib_INIReader,
+ name : 'INIReader',
+ description : 'simple .INI file parser for C++',
++ version : '0'
+ )
+ endif
+