summaryrefslogtreecommitdiffstats
path: root/main/iscsitarget
diff options
context:
space:
mode:
Diffstat (limited to 'main/iscsitarget')
-rw-r--r--main/iscsitarget/APKBUILD27
-rw-r--r--main/iscsitarget/iscsitarget-0.4.15-isns-set-scn-flag.patch20
-rw-r--r--main/iscsitarget/iscsitarget-0.4.17-build.patch23
3 files changed, 16 insertions, 54 deletions
diff --git a/main/iscsitarget/APKBUILD b/main/iscsitarget/APKBUILD
index a53e6286343..7c812a112b6 100644
--- a/main/iscsitarget/APKBUILD
+++ b/main/iscsitarget/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iscsitarget
-pkgver=1.4.19
-pkgrel=2
+pkgver=1.4.20.2
+pkgrel=0
pkgdesc="Open Source iSCSI target with professional features - userspace utils"
url="http://iscsitarget.sourceforge.net/"
license="GPL-2"
@@ -10,21 +10,28 @@ depends=
makedepends="openssl-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- $pkgname-0.4.15-isns-set-scn-flag.patch
- $pkgname-0.4.17-build.patch
ietd.initd
ietd.confd
"
-build() {
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
for i in ../*.patch; do
+ [ -r "$i" ] || continue
msg "Applying $i"
patch -p1 < $i || return 1
done
-
+}
+
+build() {
+ cd "$_builddir"
make usr || return 1
- make DISTDIR="$pkgdir" install-usr install-doc
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install-usr install-doc
for i in etc/ietd.conf etc/initiators.*; do
install -Dm640 $i "$pkgdir"/$i || return 1
@@ -33,8 +40,6 @@ build() {
install -Dm755 ../ietd.confd "$pkgdir"/etc/conf.d/ietd
}
-md5sums="9beca214c28949cce1716b49fec57de4 iscsitarget-1.4.19.tar.gz
-22512c5cf4cb62127730ce53d74ff28f iscsitarget-0.4.15-isns-set-scn-flag.patch
-c9a9b839b3afcdecd1601511ee48a171 iscsitarget-0.4.17-build.patch
+md5sums="2f23c0bfe124d79f5c20e34ef2aaff82 iscsitarget-1.4.20.2.tar.gz
9b0ca79dc47b12024c2b67d828d6d361 ietd.initd
06ba479d3533d557b8582abe6f182410 ietd.confd"
diff --git a/main/iscsitarget/iscsitarget-0.4.15-isns-set-scn-flag.patch b/main/iscsitarget/iscsitarget-0.4.15-isns-set-scn-flag.patch
deleted file mode 100644
index 4db90793d71..00000000000
--- a/main/iscsitarget/iscsitarget-0.4.15-isns-set-scn-flag.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-http://bugs.gentoo.org/180619
-
---- a/usr/isns.c
-+++ b/usr/isns.c
-@@ -215,13 +215,13 @@
-
- #if __BYTE_ORDER == __LITTLE_ENDIAN
- #define set_scn_flag(x) \
--{ \
-+({ \
- x = (x & 0x55555555) << 1 | (x & 0xaaaaaaaa) >> 1; \
- x = (x & 0x33333333) << 2 | (x & 0xcccccccc) >> 2; \
- x = (x & 0x0f0f0f0f) << 4 | (x & 0xf0f0f0f0) >> 4; \
- x = (x & 0x00ff00ff) << 8 | (x & 0xff00ff00) >> 8; \
- x = (x & 0x0000ffff) << 16 | (x & 0xffff0000) >> 16; \
--}
-+})
- #else
- #define set_scn_flag(x) (x)
- #endif
diff --git a/main/iscsitarget/iscsitarget-0.4.17-build.patch b/main/iscsitarget/iscsitarget-0.4.17-build.patch
deleted file mode 100644
index ee676a9608d..00000000000
--- a/main/iscsitarget/iscsitarget-0.4.17-build.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/usr/Makefile
-+++ b/usr/Makefile
-@@ -1,16 +1,15 @@
--CFLAGS += -O2 -fno-inline -Wall -Wstrict-prototypes -g -I../include
-+CFLAGS ?= -O2 -fno-inline -g
- CFLAGS += -D_GNU_SOURCE # required for glibc >= 2.8
-+WARNFLAGS = -Wall -Wstrict-prototypes
-+CFLAGS += $(WARNFLAGS) -I../include
- PROGRAMS = ietd ietadm
--LIBS = -lcrypto
-+LDLIBS = -lcrypto
-
- all: $(PROGRAMS)
-
- ietd: ietd.o iscsid.o conn.o session.o target.o message.o ctldev.o log.o chap.o event.o param.o plain.o isns.o
-
-- $(CC) $^ -o $@ $(LIBS)
--
- ietadm: ietadm.o param.o
-- $(CC) $^ -o $@
-
- clean:
- rm -f *.o $(PROGRAMS)