aboutsummaryrefslogtreecommitdiffstats
path: root/main/iw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/iw/APKBUILD')
-rw-r--r--main/iw/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/iw/APKBUILD b/main/iw/APKBUILD
new file mode 100644
index 00000000000..688a4d8ca9d
--- /dev/null
+++ b/main/iw/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iw
+pkgver=6.7
+pkgrel=0
+pkgdesc="nl80211 based CLI configuration utility for wireless devices"
+url="https://wireless.kernel.org/en/users/Documentation/iw"
+arch="all"
+license="ISC"
+makedepends="libnl3-dev linux-headers"
+subpackages="$pkgname-doc"
+source="https://www.kernel.org/pub/software/network/iw/iw-$pkgver.tar.xz"
+options="!check" # no test suite
+
+build() {
+ make V=1
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+7370d3b55ce43691ba84913be334c04dcdf9aa44e9556e4214d8016ddf9733b2c555ebdfbdfc814d2eba7da68501503d267ad6353b14f87b81f064f629afbef5 iw-6.7.tar.xz
+"