aboutsummaryrefslogtreecommitdiffstats
path: root/main/lcms2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lcms2/APKBUILD')
-rw-r--r--main/lcms2/APKBUILD68
1 files changed, 35 insertions, 33 deletions
diff --git a/main/lcms2/APKBUILD b/main/lcms2/APKBUILD
index 0a37ed5ec8b..58c44426f95 100644
--- a/main/lcms2/APKBUILD
+++ b/main/lcms2/APKBUILD
@@ -1,18 +1,21 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lcms2
-pkgver=2.12
-pkgrel=1
+pkgver=2.16
+pkgrel=0
pkgdesc="Color Management Engine"
-url="http://www.littlecms.com"
+url="https://www.littlecms.com"
arch="all"
-license="MIT GPL-3.0-only"
-depends_dev="libjpeg-turbo-dev tiff-dev zlib-dev"
-makedepends="$depends_dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mm2/Little-CMS/archive/$pkgver.tar.gz
+license="MIT"
+depends_dev="
+ $pkgname-plugins=$pkgver-r$pkgrel
+ libjpeg-turbo-dev
+ tiff-dev
+ zlib-dev
"
-builddir="$srcdir/Little-CMS-$pkgver"
+makedepends="$depends_dev meson"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-utils $pkgname-plugins"
+source="https://github.com/mm2/Little-CMS/releases/download/lcms$pkgver/lcms2-$pkgver.tar.gz"
# secfixes:
# 2.9-r1:
@@ -20,40 +23,39 @@ builddir="$srcdir/Little-CMS-$pkgver"
# 2.8-r1:
# - CVE-2016-10165
-prepare() {
- update_config_sub
- update_config_guess
- default_prepare
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --with-jpeg \
- --with-tiff \
- --with-zlib \
- --with-threads
- make
+ abuild-meson \
+ --default-library=both \
+ -Dfastfloat=true \
+ -Dthreaded=true \
+ -Dutils=true \
+ -Djpeg=enabled \
+ -Dtiff=enabled \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test -t4 --no-rebuild -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
utils() {
pkgdesc="Utility applications for lcms2"
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+
+ amove usr/bin
+}
+
+plugins() {
+ pkgdesc="$pkgdesc (threaded + fast_float plugins)"
+ license="GPL-3.0-or-later"
+
+ amove usr/lib/liblcms2_*.so
}
-sha512sums="4a4f3727905b1e1d514679bd83da1ead30bc5cf40cd63c3b43663fa6c5d582dc7e3540d5301393d9f01f7d2cde934975cabdcbea718cfd48c390f838d9149abb lcms2-2.12.tar.gz"
+sha512sums="
+638dd6ad6787456c8145510d18b2d0727bd0a446a13ac2934aabc9531d1156eca2a2c0fd780a453823fbd35a1895f9d8de5dc4b3cab505459dd3f0535b4e837d lcms2-2.16.tar.gz
+"