aboutsummaryrefslogtreecommitdiffstats
path: root/main/lensfun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lensfun/APKBUILD')
-rw-r--r--main/lensfun/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/lensfun/APKBUILD b/main/lensfun/APKBUILD
index f71ef95973f..7ef8a8c06e9 100644
--- a/main/lensfun/APKBUILD
+++ b/main/lensfun/APKBUILD
@@ -27,10 +27,16 @@ prepare() {
build() {
cd "$_builddir"
+ local opts=
+ case "$CARCH" in
+ arm*) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
+ esac
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_DOC=On \
- -DLENSFUN_INSTALL_PREFIX=/usr || return 1
+ -DLENSFUN_INSTALL_PREFIX=/usr \
+ $opts \
+ || return 1
make all || return 1
}