aboutsummaryrefslogtreecommitdiffstats
path: root/main/libconfig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libconfig/APKBUILD')
-rw-r--r--main/libconfig/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/main/libconfig/APKBUILD b/main/libconfig/APKBUILD
index 18c529221f1..c0e3bea6897 100644
--- a/main/libconfig/APKBUILD
+++ b/main/libconfig/APKBUILD
@@ -1,24 +1,22 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libconfig
-pkgver=1.7.2
-pkgrel=0
+pkgver=1.7.3
+pkgrel=3
pkgdesc="A simple library for manipulating structured configuration files"
-url="http://www.hyperrealm.com/libconfig/"
+url="https://www.hyperrealm.com/libconfig/libconfig.html"
arch="all"
license="LGPL-2.1-or-later"
makedepends="automake autoconf libtool texinfo"
subpackages="$pkgname-static $pkgname-doc $pkgname-dev $pkgname++:_cxx"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hyperrealm/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hyperrealm/libconfig/archive/v$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -fi
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,13 +26,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" install
}
_cxx() {
@@ -50,4 +46,6 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
-sha512sums="9df57355c2d08381b4a0a6366f0db3633fbe8f73c2bb8c370c040b0bae96ce89ee4ac6c17a5a247fed855d890fa383e5b70cb5573fc9cfc62194d5b94e161cee libconfig-1.7.2.tar.gz"
+sha512sums="
+3749bf9eb29bab0f6b14f4fc759f0c419ed27a843842aaabed1ec1fbe0faa8c93322ff875ca1291d69cb28a39ece86d512aec42c2140d566c38c56dc616734f4 libconfig-1.7.3.tar.gz
+"