aboutsummaryrefslogtreecommitdiffstats
path: root/main/libeconf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libeconf/APKBUILD')
-rw-r--r--main/libeconf/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/libeconf/APKBUILD b/main/libeconf/APKBUILD
index 002c123e315..6d0ee9e84dc 100644
--- a/main/libeconf/APKBUILD
+++ b/main/libeconf/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libeconf
-pkgver=0.4.2
+pkgver=0.6.2
pkgrel=0
pkgdesc="Enhanced Config File Parser"
url="https://github.com/openSUSE/libeconf"
@@ -10,17 +10,18 @@ license="MIT"
makedepends="meson"
checkdepends="bash"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/libeconf/archive/refs/tags/$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/libeconf/archive/refs/tags/v$pkgver.tar.gz
musl-tests.patch
+ 0001-Fix-build-with-musl-libc-on-ppc64le.patch
"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -28,6 +29,7 @@ package() {
}
sha512sums="
-d772bd90f1b3ee14c9b0ef14d80e33bcaf5527ae294a7a5612a7d8bd13441eeadbe617ed09292ec37be49c2e21f5fd805ef65c1afb55250422af2b9d6123b368 libeconf-0.4.2.tar.gz
+5646af5e76b54a9a1a05780160404dd53cdf2022085a519098223539d5c162b6ab5c1ba0ce1099a28eb411a19dd2df1a51c487a34cfe4f7f9fc3ecbce7762e59 libeconf-0.6.2.tar.gz
28431c1f80ee7815991584ef6307dabe593b4da58b9406e6f1a9cb30bfba3e925a48c83b0d3824427631bede5b1249b0c87e0d9fb55971d4ecf90805076b25dd musl-tests.patch
+88a2e97e9952fee4f0957e97877e85da3524fb8ff2dfe14bb76eb77dbf1d93335377380a1277723491d98a66739b1d35e729524f4807ad03979476e8fef62b97 0001-Fix-build-with-musl-libc-on-ppc64le.patch
"