aboutsummaryrefslogtreecommitdiffstats
path: root/main/libepoxy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libepoxy/APKBUILD')
-rw-r--r--main/libepoxy/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/libepoxy/APKBUILD b/main/libepoxy/APKBUILD
index 50d9b4b7fca..ad1943fabda 100644
--- a/main/libepoxy/APKBUILD
+++ b/main/libepoxy/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libepoxy
-pkgver=1.5.8
-pkgrel=0
+pkgver=1.5.10
+pkgrel=1
pkgdesc="Direct Rendering Manager runtime library"
url="https://github.com/anholt/libepoxy"
arch="all"
@@ -11,7 +11,7 @@ options="!check" # Requires dlvsym
depends_dev="libx11-dev"
makedepends="$depends_dev mesa-dev meson"
subpackages="$pkgname-dev"
-source="https://github.com/anholt/libepoxy/releases/download/$pkgver/libepoxy-$pkgver.tar.xz"
+source="$pkgname-pkgver.tar.gz::https://github.com/anholt/libepoxy/archive/refs/tags/$pkgver.tar.gz"
build() {
abuild-meson \
@@ -21,11 +21,11 @@ build() {
-Dx11=true \
-Dtests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -33,5 +33,5 @@ package() {
}
sha512sums="
-c2d25fa6b3bc3148ae3dc5efbd29efcb7b89569c0c9530d6eec705ebce81077f3a9aa1e2ad89d81918e69e0e67d5487637493354dff13545d9334b95ec97689c libepoxy-1.5.8.tar.xz
+6786f31c6e2865e68a90eb912900a86bf56fd3df4d78a477356886ac3b6ef52ac887b9c7a77aa027525f868ae9e88b12e5927ba56069c2e115acd631fca3abee libepoxy-pkgver.tar.gz
"