aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnftnl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libnftnl/APKBUILD')
-rw-r--r--main/libnftnl/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/libnftnl/APKBUILD b/main/libnftnl/APKBUILD
index d83b61ecf73..85cf969ac4c 100644
--- a/main/libnftnl/APKBUILD
+++ b/main/libnftnl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=libnftnl
-pkgver=1.2.2
+pkgver=1.2.6
pkgrel=0
pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
url="https://netfilter.org/projects/libnftnl"
@@ -11,14 +11,18 @@ makedepends="bash jansson-dev libmnl-dev"
provides="$pkgname-libs=$pkgver-r$pkgrel" # for backward compatibility (Alpine <3.15)
replaces="$pkgname-libs" # for backward compatibility (Alpine <3.15)
subpackages="$pkgname-dev"
-source="https://netfilter.org/projects/libnftnl/files/libnftnl-$pkgver.tar.bz2"
+source="https://netfilter.org/projects/libnftnl/files/libnftnl-$pkgver.tar.xz"
case "$CARCH" in
s390x) options="!check" ;; # FIXME
esac
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,15 +35,14 @@ build() {
}
check() {
- cd "$builddir"/tests
+ cd tests
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="
-657d48aa263043b80daa39eb8e2647c84c03b3e3a4a30b85bec1d8e4a0976075a71ad233bb384f4460d5f6662f285c12947feb8c1a6c9a534a2c9cf7ba04eee3 libnftnl-1.2.2.tar.bz2
+0c8c369eec84b0c568f0067598bece6e3be9a0fbd977e443ae3b14a5a6d842a6086ceb5426a65f8c77204709655f148c1241193f1a928f8c12154a57e3548b34 libnftnl-1.2.6.tar.xz
"