aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnftnl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libnftnl/APKBUILD')
-rw-r--r--main/libnftnl/APKBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/main/libnftnl/APKBUILD b/main/libnftnl/APKBUILD
index 0424d2b4853..85cf969ac4c 100644
--- a/main/libnftnl/APKBUILD
+++ b/main/libnftnl/APKBUILD
@@ -1,23 +1,28 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=libnftnl
-pkgver=1.1.4
+pkgver=1.2.6
pkgrel=0
pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
url="https://netfilter.org/projects/libnftnl"
arch="all"
license="GPL-2.0-or-later"
-depends_dev="libmnl-dev"
-makedepends="$depends_dev bash jansson-dev"
-subpackages="$pkgname-dev $pkgname-libs"
-source="https://netfilter.org/projects/libnftnl/files/libnftnl-$pkgver.tar.bz2"
+makedepends="bash jansson-dev libmnl-dev"
+provides="$pkgname-libs=$pkgver-r$pkgrel" # for backward compatibility (Alpine <3.15)
+replaces="$pkgname-libs" # for backward compatibility (Alpine <3.15)
+subpackages="$pkgname-dev"
+source="https://netfilter.org/projects/libnftnl/files/libnftnl-$pkgver.tar.xz"
case "$CARCH" in
s390x) options="!check" ;; # FIXME
esac
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,18 +30,19 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --with-json-parsing
+ --enable-static
make
}
check() {
- cd "$builddir"/tests
+ cd tests
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="6fe248b1340decc1ec8ae40dd0ed60b8d4b819c2f36f2399d39e13e92fc5e6f6ec693b736d6c188bff954afb2bf2dbce67d54a9e664b45f43288b2c5c6cc08f6 libnftnl-1.1.4.tar.bz2"
+sha512sums="
+0c8c369eec84b0c568f0067598bece6e3be9a0fbd977e443ae3b14a5a6d842a6086ceb5426a65f8c77204709655f148c1241193f1a928f8c12154a57e3548b34 libnftnl-1.2.6.tar.xz
+"