aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnih
diff options
context:
space:
mode:
Diffstat (limited to 'main/libnih')
-rw-r--r--main/libnih/APKBUILD56
-rw-r--r--main/libnih/disable-broken-test.patch11
-rw-r--r--main/libnih/musl-enomem-message.patch489
-rw-r--r--main/libnih/musl-fix-signals.patch12
4 files changed, 0 insertions, 568 deletions
diff --git a/main/libnih/APKBUILD b/main/libnih/APKBUILD
deleted file mode 100644
index 1670fe9a3be..00000000000
--- a/main/libnih/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=libnih
-pkgver=1.0.3
-pkgrel=5
-pkgdesc="glib-like library for embedded use"
-url="https://launchpad.net/libnih"
-arch="all"
-# gettext tests are broken
-options="!check"
-license="GPL-2.0-only"
-depends=
-depends_dev="dbus-dev expat-dev"
-makedepends="$depends_dev"
-checkdepends="linux-headers"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
- musl-fix-signals.patch
- disable-broken-test.patch
- musl-enomem-message.patch
- "
-
-prepare() {
- cd "$builddir"
- update_config_sub
- default_prepare
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --libdir=/lib \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-nls
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="fce40d2445b28c27b8838631681ca3206a4f053b2dd4fc488fc9ef98bbd3d933e3d62b82cf346be2ef1677f6457f692cf5544cd915a6bb1e5c618f98ffa101b4 libnih-1.0.3.tar.gz
-77a979b3076c4e4229359f28c2e9d4fb66d799a66d60391ab6fd7e0dfe2a615b88330a979877b105293a95ed147546596eca174f52b75beca0457c49a017d040 musl-fix-signals.patch
-b5b77b1f18d7aa5d603a0d312b785c28200c38b7bbe5c384ee576c762bd9e3163682c29dd5410baf18c5c3734f0b719602caa1de096f1758d624d94b7753066a disable-broken-test.patch
-b800c99153ad66c9d7399bc7544a0237de0c7a4ddac129509f13eb1c31805fcac31c93bbf2945da557dfc900c9ec837ec0fded1c3f9887095dae52ff6fc046ec musl-enomem-message.patch"
diff --git a/main/libnih/disable-broken-test.patch b/main/libnih/disable-broken-test.patch
deleted file mode 100644
index 15027945a7d..00000000000
--- a/main/libnih/disable-broken-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libnih-1.0.3/nih/tests/test_child.c.old 2010-09-20 18:17:01.000000000 -0500
-+++ libnih-1.0.3/nih/tests/test_child.c 2017-09-27 20:22:23.576368549 -0500
-@@ -652,7 +652,7 @@
- char *argv[])
- {
- test_add_watch ();
-- test_poll ();
-+ // test_poll ();
-
- return 0;
- }
diff --git a/main/libnih/musl-enomem-message.patch b/main/libnih/musl-enomem-message.patch
deleted file mode 100644
index 2adeff852ef..00000000000
--- a/main/libnih/musl-enomem-message.patch
+++ /dev/null
@@ -1,489 +0,0 @@
---- libnih-1.0.3/nih-dbus-tool/tests/test_parse.c.old 2010-09-20 18:17:01.000000000 -0500
-+++ libnih-1.0.3/nih-dbus-tool/tests/test_parse.c 2017-09-27 20:40:32.998734677 -0500
-@@ -1583,11 +1583,16 @@
- Signal * signal;
- Property * property;
- Argument * argument;
-+ char mem_error[280] = "test:foo:[0-9]*:[0-9]*: ";
-
- TEST_FUNCTION ("parse_xml");
- fp = tmpfile ();
- output = tmpfile ();
-
-+
-+ strerror_r(ENOMEM, mem_error+24, 254);
-+ mem_error[strlen(mem_error)] = '\n';
-+
- /* Check that a file containing a single node entity is parsed
- * successfully, returning a Node structure with no information
- * attached.
-@@ -1608,8 +1613,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1645,8 +1649,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1686,8 +1689,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1743,8 +1745,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1800,8 +1801,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1857,8 +1857,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1916,8 +1915,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -1973,8 +1971,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2047,8 +2044,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2121,8 +2117,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2195,8 +2190,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2271,8 +2265,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2345,8 +2338,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2419,8 +2411,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2493,8 +2484,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2567,8 +2557,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2641,8 +2630,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2729,8 +2717,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2817,8 +2804,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2904,8 +2890,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -2992,8 +2977,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3107,8 +3091,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3199,8 +3182,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3291,8 +3273,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3417,8 +3398,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3575,8 +3555,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3647,8 +3626,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3719,8 +3697,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3791,8 +3768,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3865,8 +3841,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -3937,8 +3912,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4023,8 +3997,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4108,8 +4081,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4194,8 +4166,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4306,8 +4277,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4426,8 +4396,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4579,8 +4548,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4652,8 +4620,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4725,8 +4692,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4800,8 +4766,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4875,8 +4840,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -4950,8 +4914,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -5027,8 +4990,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -5104,8 +5066,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -5233,8 +5194,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -5570,8 +5530,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
-@@ -5996,8 +5955,7 @@
- if (test_alloc_failed) {
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_MATCH (output, ("test:foo:[0-9]*:[0-9]*: "
-- "Cannot allocate memory\n"));
-+ TEST_FILE_MATCH (output, mem_error);
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
- continue;
diff --git a/main/libnih/musl-fix-signals.patch b/main/libnih/musl-fix-signals.patch
deleted file mode 100644
index 97ef8196dea..00000000000
--- a/main/libnih/musl-fix-signals.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- libnih-1.0.3.orig/nih/signal.c
-+++ libnih-1.0.3/nih/signal.c
-@@ -87,7 +87,9 @@
- { SIGSTKFLT, "STKFLT" },
- #endif
- { SIGCHLD, "CHLD" },
-+#ifdef SIGCLD
- { SIGCLD, "CLD" },
-+#endif
- { SIGCONT, "CONT" },
- { SIGSTOP, "STOP" },
- { SIGTSTP, "TSTP" },