aboutsummaryrefslogtreecommitdiffstats
path: root/main/libnl3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libnl3/APKBUILD')
-rw-r--r--main/libnl3/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/main/libnl3/APKBUILD b/main/libnl3/APKBUILD
index 0ddd5e3b739..3999ffab1b4 100644
--- a/main/libnl3/APKBUILD
+++ b/main/libnl3/APKBUILD
@@ -1,14 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnl3
-pkgver=3.5.0
-pkgrel=0
+pkgver=3.9.0
+pkgrel=1
pkgdesc="Library for applications dealing with netlink sockets"
url="http://www.infradead.org/~tgr/libnl/"
arch="all"
license="LGPL-2.1-or-later"
makedepends="linux-headers flex bison libtool autoconf automake"
checkdepends="check-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-cli"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-cli"
+# XXX: Since 3.6.0, the tests modify the process namespace.
+# Many of these operations are not allowed by our CI sandbox.
+# The tests should pass locally.
+#
+# See: https://github.com/thom311/libnl/commit/9102872ac24c71f5ac48b6a1f09115c872b5793b
+options="!check"
source="https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/libnl-$pkgver.tar.gz
libnl3-musl.patch
"
@@ -16,12 +22,10 @@ source="https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/l
builddir="$srcdir"/libnl-$pkgver
prepare() {
default_prepare
- cd "$builddir"
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,18 +33,16 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --disable-static \
+ --enable-static \
--enable-unit-tests
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -53,5 +55,7 @@ cli() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="9c94c09bac34297493b3ea482713d7c0865d2839b5042e5c7d1ed008e2402ab63df35a18e272f40b2cce27d0c31dc733fe7e4b2d376e7ca847a2b0d5e90de50c libnl-3.5.0.tar.gz
-2b9b569c00b9e29930a83e88264e9cb63a4991bd89a04f2fc4b4c468a2a73309d9463f0b9e4a945e614c0f831a68fc99c5768a0f2214a0dde00785215e24e1dc libnl3-musl.patch"
+sha512sums="
+b6f3633d1920e61645c97f4c4c4419444e7fd66aa3b67b0a73bc29df24cf27065542a62a9c2581f90d0c153247922ce5c649b7da51c0fead6afceaf4d0361dce libnl-3.9.0.tar.gz
+2b9b569c00b9e29930a83e88264e9cb63a4991bd89a04f2fc4b4c468a2a73309d9463f0b9e4a945e614c0f831a68fc99c5768a0f2214a0dde00785215e24e1dc libnl3-musl.patch
+"