aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpciaccess/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libpciaccess/APKBUILD')
-rw-r--r--main/libpciaccess/APKBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/main/libpciaccess/APKBUILD b/main/libpciaccess/APKBUILD
index 504715127ff..7ef6211a1f4 100644
--- a/main/libpciaccess/APKBUILD
+++ b/main/libpciaccess/APKBUILD
@@ -1,31 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpciaccess
-pkgver=0.16
+pkgver=0.18.1
pkgrel=0
pkgdesc="X11 PCI access library"
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org/"
arch="all"
license="X11"
options="!check" # No test suite.
-makedepends="util-macros"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/lib/$pkgname-$pkgver.tar.bz2
- limits_h.patch"
+depends="hwdata-pci"
+makedepends="meson util-macros"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.x.org/releases/individual/lib/libpciaccess-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr
- make
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="2f250048a270dfc0823d4bdd613aa272c58a80eaafd922850f56c4b6f7a45a263ed4cf521b52b49f04484ea44ebefb7407d079aa058318a5751ffb181e38fed1 libpciaccess-0.16.tar.bz2
-331a498059d8b2bfd0a7da0ced3616266ebc129b785090ef1dc19cd645b013428c60d5678fc080bd15ecaf7598ec8b1084509d6bea5d563101169a449b6fe75b limits_h.patch"
+sha512sums="
+ef27999446e735df2331e94219ee3dafe9198a2472bb452f63ef9c9c446d5431f9e231e224cfabdeba1402974a5a0064546f9abced4d1770f994f5fc0c2b3310 libpciaccess-0.18.1.tar.xz
+"