aboutsummaryrefslogtreecommitdiffstats
path: root/main/libressl
diff options
context:
space:
mode:
Diffstat (limited to 'main/libressl')
-rw-r--r--main/libressl/APKBUILD6
-rw-r--r--main/libressl/ssl-libcompat.patch6
2 files changed, 6 insertions, 6 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 84cf67ba0e8..86a81b4e4ca 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -10,7 +10,7 @@
# - CVE-2017-8301
#
pkgname=libressl
-pkgver=3.0.2
+pkgver=3.1.2
_namever=${pkgname}${pkgver%.*}
pkgrel=0
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
@@ -93,7 +93,7 @@ _libs() {
fi
}
-sha512sums="19226da3bc9776e1da40b8e94dfa53564d5e6acc80edee539ba12d7a75c1bb8c0603e7633f26a6ef8b12adc56bb677ccda448575aa6be2ad3df5447465a4b080 libressl-3.0.2.tar.gz
+sha512sums="b024c5661777daa73feff7085ce7be76a2e766d2f3cb5ca35c208c471e5651a365252758ca36782e20cdfb2bc8171919a08ad592420878a5c95fbe646f5288c8 libressl-3.1.2.tar.gz
9f1628fbc2a697b6570353920d784b161ca0a122047066d8bee15225bad1e5271aa2ed72b145506bcd4ffe58b35da2caf38c4a048db7e014dabd16b5eba44581 starttls-ldap.patch
-ef8150843f5aae577a859198439673591764fb3ab1da03436607328962f084356fd7f793484c3ad5f2294bd9e8dad15644c311b0da811acbc83eed4b71c0145a ssl-libcompat.patch
+18e72b7db28664ee4e294a4a461e48daa90be9e9323584112a5878fd56a578d02f4730c7c788f57cc39b2bc35447df0a47a4391077d764d953419890ad511d35 ssl-libcompat.patch
4c992872addbe4fd612ba9e3f859b5ba69b448aafa7676751ca7ca09bbcfc47a2a1cad468c235f8d1a65c65e8efb38f27c512a32b444346c39ec0d8dcfbcd346 s_client-add-options-verify_.patch"
diff --git a/main/libressl/ssl-libcompat.patch b/main/libressl/ssl-libcompat.patch
index c28c33aa5cb..4af15c3a31c 100644
--- a/main/libressl/ssl-libcompat.patch
+++ b/main/libressl/ssl-libcompat.patch
@@ -2,12 +2,12 @@ diff --git a/ssl/Makefile.am b/ssl/Makefile.am
index 99d138a..9d8f1f4 100644
--- a/ssl/Makefile.am
+++ b/ssl/Makefile.am
-@@ -7,7 +7,7 @@ EXTRA_DIST += CMakeLists.txt
+@@ -7,7 +7,7 @@
EXTRA_DIST += ssl.sym
libssl_la_LDFLAGS = -version-info @LIBSSL_VERSION@ -no-undefined -export-symbols $(top_srcdir)/ssl/ssl.sym
--libssl_la_LIBADD = $(abs_top_builddir)/crypto/libcrypto.la
-+libssl_la_LIBADD = $(abs_top_builddir)/crypto/libcrypto.la $(abs_top_builddir)/crypto/libcompat.la
+-libssl_la_LIBADD = $(abs_top_builddir)/crypto/libcrypto.la $(PLATFORM_LDADD)
++libssl_la_LIBADD = $(abs_top_builddir)/crypto/libcrypto.la $(abs_top_builddir)/crypto/libcompat.la $(PLATFORM_LDADD)
libssl_la_SOURCES = bio_ssl.c
libssl_la_SOURCES += bs_ber.c