aboutsummaryrefslogtreecommitdiffstats
path: root/main/libseccomp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libseccomp/APKBUILD')
-rw-r--r--main/libseccomp/APKBUILD30
1 files changed, 21 insertions, 9 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index 164fc0c2140..43b39a4549a 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -1,20 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Contributor: Dan Williams <dan@ma.ssive.co>
pkgname=libseccomp
-pkgver=2.4.3
-pkgrel=0
-pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="interface to the Linux Kernel's syscall filtering mechanism"
url="https://github.com/seccomp/libseccomp"
arch="all"
license="LGPL-2.1-or-later"
depends_dev="linux-headers"
-makedepends="$depends_dev"
+makedepends="$depends_dev gperf cython python3 python3-dev py3-setuptools"
checkdepends="bash"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc py3-$pkgname:py3"
source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
remove-redefinition-prctl.patch
- fix-performace-regression.patch
"
case "$CARCH" in
@@ -33,6 +32,8 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --enable-python \
+ --enable-static \
--localstatedir=/var
make
}
@@ -44,6 +45,9 @@ check() {
ppc64le|s390x) rm -f tests/36-sim-ipc_syscalls.tests \
tests/37-sim-ipc_syscalls_be.tests;;
esac
+ # fix python shebang
+ sed -i -e 's@cmd /usr/bin/env python @cmd /usr/bin/env python3 @' tests/regression
+ sed -i -e 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@' tests/*.py
make check
}
@@ -51,6 +55,14 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7b7af2e98493243ffe1934fefff5723b24ae9b9bdc4bf039343ee8456c15acb0ea34e81ec292a41143848272aeca794ef92ad38fc3f42c77465170cb540479ef libseccomp-2.4.3.tar.gz
+py3() {
+ pkgdesc="Python 3 bindings for $pkgname"
+ depends="$depends $pkgname python3"
+
+ amove usr/lib/python3*
+}
+
+sha512sums="
+f630e7a7e53a21b7ccb4d3e7b37616b89aeceba916677c8e3032830411d77a14c2d74dcf594cd193b1acc11f52595072e28316dc44300e54083d5d7b314a38da libseccomp-2.5.5.tar.gz
f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch
-c9dd939552089b006e03b94a323c9932806b0681b493b3365c291273cff4485b1066a73919a85dff238fc10e33cd4f67c99645049b0696ba0d6f229aac8d8b81 fix-performace-regression.patch"
+"