aboutsummaryrefslogtreecommitdiffstats
path: root/main/libseccomp
diff options
context:
space:
mode:
Diffstat (limited to 'main/libseccomp')
-rw-r--r--main/libseccomp/APKBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index 2652ed39023..43b39a4549a 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -1,17 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Contributor: Dan Williams <dan@ma.ssive.co>
pkgname=libseccomp
-pkgver=2.5.0
+pkgver=2.5.5
pkgrel=1
-pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
+pkgdesc="interface to the Linux Kernel's syscall filtering mechanism"
url="https://github.com/seccomp/libseccomp"
arch="all"
license="LGPL-2.1-or-later"
depends_dev="linux-headers"
-makedepends="$depends_dev gperf"
+makedepends="$depends_dev gperf cython python3 python3-dev py3-setuptools"
checkdepends="bash"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc py3-$pkgname:py3"
source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
remove-redefinition-prctl.patch
"
@@ -32,6 +32,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
+ --enable-python \
--enable-static \
--localstatedir=/var
make
@@ -44,6 +45,9 @@ check() {
ppc64le|s390x) rm -f tests/36-sim-ipc_syscalls.tests \
tests/37-sim-ipc_syscalls_be.tests;;
esac
+ # fix python shebang
+ sed -i -e 's@cmd /usr/bin/env python @cmd /usr/bin/env python3 @' tests/regression
+ sed -i -e 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@' tests/*.py
make check
}
@@ -51,5 +55,14 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="00ef5aeb4db8dafb546ae680b2d6d9b6aeed008df805d0f28f9dd15c074ff6ea7a5e5131ab503825b8011c59aa23046baedd5849ca040aa73352f43ab2d602ae libseccomp-2.5.0.tar.gz
-f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"
+py3() {
+ pkgdesc="Python 3 bindings for $pkgname"
+ depends="$depends $pkgname python3"
+
+ amove usr/lib/python3*
+}
+
+sha512sums="
+f630e7a7e53a21b7ccb4d3e7b37616b89aeceba916677c8e3032830411d77a14c2d74dcf594cd193b1acc11f52595072e28316dc44300e54083d5d7b314a38da libseccomp-2.5.5.tar.gz
+f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch
+"