aboutsummaryrefslogtreecommitdiffstats
path: root/main/libsrtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libsrtp/APKBUILD')
-rw-r--r--main/libsrtp/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/main/libsrtp/APKBUILD b/main/libsrtp/APKBUILD
index 9a0101850ca..d68369ab983 100644
--- a/main/libsrtp/APKBUILD
+++ b/main/libsrtp/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsrtp
-pkgver=2.4.2
-pkgrel=2
+pkgver=2.5.0
+pkgrel=1
pkgdesc="implementation of the Secure Real-time Transport Protocol (SRTP)"
url="https://github.com/cisco/libsrtp"
arch="all"
license="BSD-3-Clause"
-makedepends="doxygen libpcap-dev meson ninja openssl-dev"
-subpackages="$pkgname-static $pkgname-dev"
+makedepends="doxygen libpcap-dev meson openssl-dev"
+subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/cisco/libsrtp/archive/v$pkgver.tar.gz"
case "$CARCH" in
@@ -23,20 +23,13 @@ build() {
}
check() {
- meson test --no-rebuild -v -C builddir
+ meson test --no-rebuild --print-errorlogs -C builddir
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C builddir
}
-static() {
- depends=""
- pkgdesc="$pkgdesc (static library)"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$builddir"/builddir/*.a "$subpkgdir"/usr/lib
-}
-
sha512sums="
-6e4805e6d34b2050a6f68f629b0b42356b1d27f2cbaa6cc6166e56957609c3d9aa6b723dcc674e5c74180d122d27badd2f9496639ccb1e0c210b9e1f7949d0e2 libsrtp-2.4.2.tar.gz
+bd679ab65ccf22ca30fe867b9649a0b84cfa6fad6e22eb10f081141632f6dd56479a04d525b865f11fd46007303ca211065d9c170e4820d6ea7055403702340a libsrtp-2.5.0.tar.gz
"