aboutsummaryrefslogtreecommitdiffstats
path: root/main/libsrtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libsrtp/APKBUILD')
-rw-r--r--main/libsrtp/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/main/libsrtp/APKBUILD b/main/libsrtp/APKBUILD
index 3a2a32f40ef..2903d6d4ddd 100644
--- a/main/libsrtp/APKBUILD
+++ b/main/libsrtp/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsrtp
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=0
pkgdesc="An implementation of the Secure Real-time Transport Protocol (SRTP)"
url="http://srtp.sourceforge.net"
@@ -12,7 +12,6 @@ subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/cisco/libsrtp/archive/v$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
# Required for loading libsrtp2.so.1
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$builddir" make runtest
}
@@ -42,4 +39,4 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
-sha512sums="3a5214b02199ae8dff45a2ed225ed9b1dcb75a9c6b07669e23bf86f97ad26e3e22b4930acdf3c56b21b605211a89a53a17c61602195b391a5b29a09823ba868c libsrtp-2.2.0.tar.gz"
+sha512sums="34b1a01cb9a75aed175be09aadd2827224203b9801becc3fbc5214667cce79c3b87b0f59e4315583863ab5a2cc4fc81d56ab604a5e4c984518b8a8a2a7b77461 libsrtp-2.3.0.tar.gz"