aboutsummaryrefslogtreecommitdiffstats
path: root/main/libssh2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libssh2/APKBUILD')
-rw-r--r--main/libssh2/APKBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/main/libssh2/APKBUILD b/main/libssh2/APKBUILD
index 0089411ed27..ac3f82698ab 100644
--- a/main/libssh2/APKBUILD
+++ b/main/libssh2/APKBUILD
@@ -1,18 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libssh2
-pkgver=1.10.0
+pkgver=1.11.0
pkgrel=2
pkgdesc="library for accessing ssh1/ssh2 protocol servers"
url="https://libssh2.org/"
arch="all"
license="BSD-3-Clause"
-makedepends_host="openssl1.1-compat-dev zlib-dev"
+makedepends_host="openssl-dev>3 zlib-dev"
+checkdepends="bash"
subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc"
-source="http://www.libssh2.org/download/libssh2-$pkgver.tar.gz
+source="https://www.libssh2.org/download/libssh2-$pkgver.tar.gz
+ add-strict-KEX-to-fix-CVE-2023-48795-Terrapin-Attack.patch
"
-options="!check" # FIXME: debug why integration test fails on builders but not rootbld
# secfixes:
+# 1.11.0-r1:
+# - CVE-2023-48795
# 1.9.0-r1:
# - CVE-2019-17498
# 1.9.0-r0:
@@ -28,9 +31,7 @@ options="!check" # FIXME: debug why integration test fails on builders but not r
# - CVE-2019-3862
# - CVE-2019-3863
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,28 +41,22 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--with-crypto=openssl \
- --with-libssl-prefix=$CBUILDROOT/
+ --with-libssl-prefix=$CBUILDROOT/ \
+ --disable-docker-tests
make
}
check() {
- cd "$builddir"
- make check
+ # with --disable-docker-tests above only mansyntax.sh and test_simple are
+ # run, other tests require docker and a running sshd
+ make check VERBOSE=1
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-static() {
- depends=""
- pkgdesc="$pkgdesc (static library)"
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
-}
-
sha512sums="
-e064ee1089eb8e6cd5fa2617f4fd8ff56c2721c5476775a98bdb68c6c4ee4d05c706c3bb0eb479a27a8ec0b17a8a5ef43e1d028ad3f134519aa582d3981a3a30 libssh2-1.10.0.tar.gz
+ef85e152dc252bd9b1c05276972b9c22313f5d492743dde090235742746d67f634f2a419eff9162132e2274c8582113b75279b074e0c7b34b2526b92fd1a1e8e libssh2-1.11.0.tar.gz
+5a3fc886962032d4f0a244942c0db216bb108d57ac79f454ec05527e76a744689a5dc89d6d20b5abc2a0b75144d7c2eb95286f23190ecaf9bbb456fb14922125 add-strict-KEX-to-fix-CVE-2023-48795-Terrapin-Attack.patch
"