aboutsummaryrefslogtreecommitdiffstats
path: root/main/libva/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libva/APKBUILD')
-rw-r--r--main/libva/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/libva/APKBUILD b/main/libva/APKBUILD
index 49ef2689ad6..b2b1f09feb9 100644
--- a/main/libva/APKBUILD
+++ b/main/libva/APKBUILD
@@ -16,6 +16,13 @@ subpackages="$pkgname-dev"
source="https://github.com/01org/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
prepare() {
+ ( if [ -f "$startdir"/../libva-glx/APKBUILD ]; then
+ _v=$pkgver
+ . "$startdir"/../libva-glx/APKBUILD
+ if [ "$_v" != "$pkgver" ]; then
+ die "libva and libva-glx needs to be same version"
+ fi
+ fi )
cd "$builddir"
default_prepare
# we need to regen the configure script which will unconditionally