aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxau/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxau/APKBUILD')
-rw-r--r--main/libxau/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/main/libxau/APKBUILD b/main/libxau/APKBUILD
index 8bd22dc5c51..1920c2ff48c 100644
--- a/main/libxau/APKBUILD
+++ b/main/libxau/APKBUILD
@@ -1,20 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxau
-pkgver=1.0.9
-pkgrel=0
+pkgver=1.0.11
+pkgrel=3
pkgdesc="X11 authorisation library"
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org/"
arch="all"
license="MIT"
-depends=
makedepends="xorgproto util-macros"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/lib/libXau-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/lib/libXau-$pkgver.tar.xz"
builddir="$srcdir"/libXau-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,15 +22,14 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
- install -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="3ca454ba466a807ea28b0f715066d73dc76ad312697b121d43e4d5766215052e9b7ffb8fe3ed3e496fa3f2a13f164ac692ff85cc428e26731b679f0f06a1d562 libXau-1.0.9.tar.bz2"
+sha512sums="
+f56abba3bef3fdd4739dfa69367a4251b5fab7c89194c9aece9efa66b9ebbf0736690cc9bd654aab19d9db377e4b9a5268c9c020b3d293bb5351bff5fe75a4dd libXau-1.0.11.tar.xz
+"