aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxcb/APKBUILD')
-rw-r--r--main/libxcb/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index 31009de0c1e..53b56729332 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcb
pkgver=1.13
-pkgrel=0
+pkgrel=1
pkgdesc="X11 client-side library"
-url="https://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org"
arch="all"
-license="custom"
+license="MIT"
depends=
subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
-makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
+makedepends="$depends_dev libpthread-stubs libxdmcp-dev libxslt python3"
source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
@@ -23,14 +23,13 @@ build() {
--prefix=/usr \
--enable-xkb \
--enable-xinput \
- --disable-xprint \
+ --disable-xprint
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
check() {