aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxdamage/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxdamage/APKBUILD')
-rw-r--r--main/libxdamage/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/libxdamage/APKBUILD b/main/libxdamage/APKBUILD
index 0ddd9126a90..39d328bbcad 100644
--- a/main/libxdamage/APKBUILD
+++ b/main/libxdamage/APKBUILD
@@ -7,13 +7,20 @@ url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
depends=
+depends_dev="xproto damageproto libxfixes-dev libx11-dev fixesproto"
makedepends="pkgconfig libxfixes-dev damageproto xextproto"
subpackages="$pkgname-dev"
source="http://xorg.freedesktop.org/releases/individual/lib/libXdamage-$pkgver.tar.bz2"
-depends_dev="xproto damageproto libxfixes-dev libx11-dev fixesproto"
+_builddir="$srcdir/libXdamage-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/libXdamage-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \